Supra Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Hi guys,

I noticed my car was smelling a bit rich and boost levels were a bit inconsistent. Today I pulled the MAF sensor, gave it a clean, went over the boost hoses and tighten them all up and it seemed to make a difference.



First pull was at 60% on the boost controller (5% gain):





Notice how the boost hits it's peak and then starts to drop off?



Second pull - 65% boost 5% gain







Last pull - 69% boost 5% gain







The boost was dropped off again, but seemed to hold on steady after the gear change. Now, am I being a numpty here? Is this quite normal is it is something that needs tweaking in the boost controller (Greddy Profec)?



Any help would be appreciated.
 

·
Game Over
Joined
·
1,256 Posts
That slight drop towards Redline is normal as your running higher boost, because your compressor efficiency is slightly dropping off up top. When I ran 19 psi on pump gas on stock twins, it used to taper off to 16-17 psi towards redline, even with the wastegate spring mod. I made that spring adjustable, tightened it on that actuator as much as I can, backed down the duty cycle on the boost controller, and I made the same 19 peak boost, but I reduced that drop to 18 psi at redline.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #3
Sweet. Awesome news... Something I can forget about now then! Thanks for shedding some light on that mate. :)
 

·
Boost Junkie
Joined
·
12,624 Posts
It also wouldn't hurt to do a boost leak test as well.

Steve
 

·
Registered
Joined
·
15 Posts
Discussion Starter #5
That's the next step Steve, definitely.
 
1 - 5 of 5 Posts
Top