Supra Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter #1
i have a autometer boost gauge and it only reads 4-5 psi max dont understand it brand new 57 trimCT turbo and wastegate from PT. With shims i only could reach 6psi. When the car is at idle whats the vac supposed to be. I think im going to try boost controller this week if that doesnt work im going to purchase the HPF IC kit and see if that helps cause maybe i have a leak somewhere. It has to be small cause i just inspected all those connections. And where is the best place to plug in gauge vac line right into the throttle body right.
 

·
Registered
Joined
·
3,727 Posts
you shouldnt just inspect the hoses and clamps. you should do a pressure test and check for boost leaks that way.
 

·
Registered
Joined
·
49 Posts
Discussion Starter #5
its ok i fiqured it out with some help. So the guy before me just hooked it up so that the needle would move thank god i didnt shim that wastegate anymore. Cause that thing was pissing me off
 

·
what would jesus drift?
Joined
·
987 Posts
it should be hooked up after the tb, on the fire wall side of the intake mani, i found a vaccume nipple..
 

·
Registered
Joined
·
375 Posts
that seems high for idle vac, unless sup has high vac it should be 15-17 is standard i believe,
 

·
Always playing catch up
Joined
·
1,632 Posts
nose-gobblin said:
that seems high for idle vac, unless sup has high vac it should be 15-17 is standard i believe,
um more like trent said, 20 is about as least you want (mines at 18-19 cause of a valve seal thats on its way out) anything greater is fine

<l><l>

edit: meant while warm
 
1 - 9 of 9 Posts
Top