Supra Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1,253 Posts
Discussion Starter #1
ok i have two problems, heres the first one, when my car is cold i can easily do 8psi and as its warmed up (about 20 min of driving i can only do 5psi) i checked for leaks, went thru 3 bov's and i'm running out of ideas. Could it be a tired wastegate? i was gonna try shimming it what you guys thing? and the other problem is say i rev my motor and let it go it will die, it doesn't really stumble. I have a hks replica with a recirc fitting. I neve rhad a prob wit my stock bov, but had the same problem with the hks and a turboxs. Now i have about a foot long hose that the air has to recirc thru b 4 hitting the accordian. Whereas the stock bov sits on the accordian, do you guys think this can cause stalling? maybe the air released can't reach the accordian with enough pressure since it has to travel thru a foot long hose? i could move the bov but then it wouldn't look as nice the way its setup now. thanks
 

·
BMM
Joined
·
2,329 Posts
this happens to me, I'm not 100% sure on what it is, but I think its the air not getting resirculated (fast enough in your case). I just keep mine in gear until I reach 1000rpms while stopping before I take it out of gear. that helps. Also, if you feel like its going to die, tap the gas around 1500rpms, it should keep it alive.

Thats all I got.
 

·
Registered
Joined
·
1,253 Posts
Discussion Starter #3
hmm that could be it, i don't know why i never thought of that, i'm going to try to move the bov closer to the accordian this weekend
 
1 - 3 of 3 Posts
Top