Supra Forums banner

1 - 20 of 65 Posts

·
Registered
Joined
·
1,953 Posts
Discussion Starter #1
got the SR in and running well!

heres some pics from day one of my swap... thanks Mr Wob for the help and the pics!

ka out!


sooo greasy!


sr in!


mr wob turnin wrenches!



more pics of finished product to come.. still workin out some kinks but im boostin! its my first turbo car and im lovin it :D
 

·
Wobbiest: Three Laws Safe
Joined
·
6,137 Posts
Wob is always here to help - sorry I couldnt stay longer to finish it up with you.
 

·
Passion Driven
Joined
·
1,689 Posts
If you would have invited me along I would have came.

But then again I probably would have distracted Wob away from the motor work....tee hee...

Congrats, though ;)

What are the "Kinks" left over?
 

·
Wobbiest: Three Laws Safe
Joined
·
6,137 Posts
PhoeniXDownVII said:
If you would have invited me along I would have came.

But then again I probably would have distracted Wob away from the motor work....tee hee...

Congrats, though ;)

What are the "Kinks" left over?
Dont be flattered I get distracted by birds, cars, air, bags in the air, insects, camels etc.
 

·
Moderator
Joined
·
4,109 Posts
Mr. Wob said:
Dont be flattered I get distracted by birds, cars, air, bags in the air, insects, camel TOE etc.
Fixed
 

·
Registered
Joined
·
1,953 Posts
Discussion Starter #16 (Edited)
PhoeniXDownVII said:
If you would have invited me along I would have came.

But then again I probably would have distracted Wob away from the motor work....tee hee...

Congrats, though ;)

What are the "Kinks" left over?
running rich.. dunno if its just my atmo bov.. could be the o2 sensor im running too. im not sure yet. i bought s14 fmic kit because i was planning on going with the vvti s14 motor, but i would have had to wait another 3 months so i just got the redtop.. so my ic pipes were wrong so theyre kinda rigged at the moment. gonna take it to an exhaust shop and have them bend up some custom pipes. i broke an ignitor with the hoist so #3 is kinda rigged too.. my buddy has like 8 of them sitting around he told me i can have one just waiting on it. rad fan is on a switch at the moment.. have an adjustable relay that i need to wire. gotta clean up some wiring and vacuum lines.. kinda gotta wait on the new ic pipes for the vaccum lines though.. wastegate line is on cold side at the moment- looks pretty ugly. need a new exhaust too... i bought the cheap shit ssautochrome and it scrapes on EVERYTHING. wish i didnt waste the money on it but i suppose the dp and test pipe alone were worth the cost. aside from all that little shit, the car is running and boosting great. im lovin it

edit: gauges arent in yet either because they dont fit where i wanted them... now i gotta find an alternative. dont want an a-pillar pod but i might just have to go that way :(


cds01 said:
about how long did it take?
about a week and a half. had the whole first weekend, then worked until sunset every day after work. the wiring confused me for a minute, i didnt realize the power plugs had to come back through the firewall... i was using an s13 writeup.. lol.

she started up on the first crank though!
 

·
Wobbiest: Three Laws Safe
Joined
·
6,137 Posts
homo battery. I still like that sexy guy in the gray hat though :gaysex:
 
1 - 20 of 65 Posts
Top