Supra Forums banner

21 - 38 of 38 Posts

·
ƒ=1/2π(√k/m)
Joined
·
9,913 Posts
Dude, you were right. I took entire system apart and replaced every hose. I also did a tune up, replaced wires, removed the egr, and added a new thermostat. Now the car responds and drives like new. My only issue now is that the cooling temp needle won't move from cold. I let it run with the heat on. I get heat in the cabin and still, the needle won't move. Any suggestions?.,,.Thanks.
Do you have the coolant temperature sensor plugged in?
Should be located on the top of the thermostat housing.
Since you have heat in the car, I doubt the engine isn't getting up to temperature.
I'd check the sensor and wiring.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #22
I think it's the wire. I'm going to look at it again. Also, after this overhaul, now the clutch is slipping...lol
 

·
ƒ=1/2π(√k/m)
Joined
·
9,913 Posts
I think it's the wire. I'm going to look at it again. Also, after this overhaul, now the clutch is slipping...lol
Make sure your clutch pedal pre-load isn't engaging the master cylinder... but it might just be expected if it's old and has a lot of miles on it.
 

·
Registered
Joined
·
911 Posts
OP, thanks for updating us to let us know that you solved the issue. Far too many threads are just left open ended on car forums the world over...

As for your temp needle, I'm with Brent on this one, I bet that in all your excitement, you simply forgot to plug the wire back onto the sensor in the water neck. Should be a single pole sensor, if my memory is correct.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #29
TY. It was actually the wire broke off the connector. Since we're still here, I now have the clutch issue. I tried adjusting it this morning and couldn't move the rod enough and it's still slipping. I was able to raise the height a bit, but it didn't change the slipping. Also, I noticed that it slips when the car is warm and when driving it like a BMW. When driving it like a Mercedes, it drives normal...LOl.. Any suggestions?..
 

·
Registered
Joined
·
19 Posts
Discussion Starter #31
All this started happening when I replace the Master, but it's been about a year though..
 

·
ƒ=1/2π(√k/m)
Joined
·
9,913 Posts
All this started happening when I replace the Master, but it's been about a year though..
On the transmission, there is an "inspection window" you can remove.
If you're really curious, you could remove the panel to view inside the bellhousing.
While someone depresses the clutch pedal, you can watch the pressure plate flex.
The R-154 is a pull type clutch, so with the pedal out the pressure plate should be fully released.
If there's somehow some pressure still on the hydraulic line, it could conceivably slip.

How many miles are on the clutch/flywheel?
 

·
Registered
Joined
·
19 Posts
Discussion Starter #33
That was my next question. I don't know how many miles. The car has 147k but, I don't know if the PO changed it.
 

·
ƒ=1/2π(√k/m)
Joined
·
9,913 Posts
That was my next question. I don't know how many miles. The car has 147k but, I don't know if the PO changed it.
My stock clutch started slipping around that mileage as well.
Best to upgrade it anyway if you're planning on doing some basic performance mods.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #35
I'm leaving car stock. I did noticed the PO shimmed the turbo with 2 washers. This clutch was working perfectly until the master change, and I only noticed the slip when someone wouldn't move out of the way and I downshifted to go around and the car just sat there.
 

·
Registered
Joined
·
32 Posts
I'm leaving car stock. I did noticed the PO shimmed the turbo with 2 washers. This clutch was working perfectly until the master change, and I only noticed the slip when someone wouldn't move out of the way and I downshifted to go around and the car just sat there.
This may sound painfully obvious, but even I still do it. Make sure youre fully engaging that gear when you down shift. I still sometimes go to smack that downshift into the backseat and let her eat but leave it halfway pulled like an idiot so I just sit there revving my engine because I completely failed a SICK revmatch.


oh. Just a me problem?
 
21 - 38 of 38 Posts
Top