Supra Forums banner

1 - 5 of 5 Posts
S

·
Guest
Joined
·
0 Posts
Discussion Starter #1
I have been noticing that my brake light and warning light have been coming on when my Parking brake is not even on. I was wondering if anybody has had this problem before? Is it the sensor or is it something to do with the brake fluid or something else?
 

·
Registered
Joined
·
763 Posts
There are two inputs to the ECU that trigger the break warning light. The first sensor reads from the handbreak and the second sensor takes input from the break resivior level.

Unplug the sensor going to the brake fluid resivior and check to see if the problem stops. If it stops then you most likely either have low break fluid or the sensor in the resivior has gone bad. They actually go bad quite often. Some of the Lexus cars use the same resivior and they have the same problem quite often. If this is the problem you can simply keep the sensor unplugged and just check the break fluid level periodically to make sure it does not run low (cheap solution.) OR you could replace the entire break resivior.

If unplugging the sensor does not get rid of the problem then signal is comming from the hand break sensor.

This should at least help you isolate where the problem is comming from.

Hope this helps.

-pete
 

·
Registered
Joined
·
353 Posts
Is it happening when you are braking?

I had this issue when I first got my Supra, it was because I was low on brake fluid.

-m
 
S

·
Guest
Joined
·
0 Posts
Discussion Starter #4
It happens when I brake, but I have noticed latly that it is staying on longer. Used to if I had to brake hard it would come on and then go off. But now even if I brake slightly it will come on and stay on like this morning it stayed on for about 15 sec's.
 

·
Premium Member
Joined
·
6,923 Posts
People people, check the archives before posting topics. This was covered about a week ago. You are low on brake fluid.
Peter
 
1 - 5 of 5 Posts
Top