Supra Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
405 Posts
Discussion Starter · #1 ·
Ok here is my problem, The brake light is coming on ocacionally when i press the brake, I can hear a clicking sound when the light goes on and then another clicking sound when the light goes off.

It happens more often in the mornings when is really cold.
I had a compustar alarm/remote starter installed about 4 weeks ago and I am wondering if that might be the problem because the clicking sound I hear is the same as the clicking sound the remote starter makes when the car is set up to remote start when I turn off the car and depress the brake.

Any suggestions?
 

·
Hardtopper
Joined
·
13,044 Posts
Same thing is happening on my car but I have the Viper 791VX
 

·
Registered
Joined
·
405 Posts
Discussion Starter · #4 ·
Do you have an automatic or manual?
It is a 5speed manual. One of the reasons I decided to go with compustar was that I heard their alarm/starters were pretty good and safe for standards, but now I dont know if the installation has anything to do with the brake light issue.
 
G

·
With manual transmission mode, there are other things triggering when you press the brake. There are some relays set up to perform certain actions when the brakes are pressed (Like cancel a remote start, lock the doors, etc. It's likely the remote start cancel that's causing the noise you hear.

The main ignition line is a sensor, too. It tries to determine if the key is on or off by sensing voltage on that line. When the car is cold and at idle, sometimes the voltage is a bit low, and the sensor thinks that the key might be turned off. When that happens, it triggers the relay, trying to shut down the engine. Of course the key is NOT off, so the engine keeps running, which the system knows because it's still getting a tach signal. When you release the brake, it clicks the relay open again, so that it can prepare for remots start mode again.
 
1 - 5 of 5 Posts
Top