Supra Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1,181 Posts
Discussion Starter · #1 ·
Okay, i bought the rear brake & rotors from autozone to replace my old and busted one last month.


Eversince i install it, it's been making these squealing noises. For the entire month, i've taking my brakes apart so many times trying to figure out what's wrong.


At first, the noises were minimal and bareable. Now, everytime i use the brake, it's just embarrassing.

It doesn't make any noise if i push the brake down hard. It's just if i use it lightly as if to slow down for a red light, it just squeal like crazy.


Now i've taken my front & rear brakes apart so many times trying to clean it, grease it, & check for damages. But it's still doing it! arrrr...


help? Could it be the brake pads itself? i noticed that on one of the pad, half of it is not the same color as the other half.
 

·
Registered
Joined
·
201 Posts
I had a similar problem with pads other than Toyota ones. When I went back to toyota the squeak stopped. Stick with toyota pads I think you will have a better chance. Try some brake quite spray on what you have. Good luck! I know how frustrating it can be.
 

·
Registered
Joined
·
432 Posts
I got the same problem going for me as well. Got all new OEM rotors and pads plus 2 new calipers up front and they still squeek when stopping. Its annoying as hell. What if you go with aftermarket cross drilled rotors and some Green Stuff pads? Do you think we will be better off?
 

·
Premium Member
Joined
·
4,409 Posts
ya probably a problem with the pad or something got in between the pad and the rotor, is it just one or all four? also make sure the shims on there are on properly and they arent touching the rotor, dust guards as well.

IF all fails take the pads back.

Ang
 
1 - 5 of 5 Posts
Top