Supra Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
81 Posts
Discussion Starter · #1 ·
on hard boost or takeoff after idling at a stop light. greyish blue smoke (mobil 1). Is this the turbos, valve seals, or rings?

Car has 110k miles on it. Full exhaust, tuned, boost is raised to 16 plus stu mod. Factory turbos.

What are the chances, if its the turbo, that this is the first turbo compared to the second? If it is only 1 turbo, (which i suspect it is), is it easy to replace just that turbo without removing the rest of the exhaust side? While this is a great excuse to go single, Im on a budget so if i can get away with replacing just one, that would be super.

Thanks guys!
-Ryan
 

·
Registered
Joined
·
1,784 Posts
could be both valve seals and the turbos going....
If you are smoking while boosting hard you can bet its the turbos...if you see a puff of smoke after sitting idle at a traffic light or something ..that is your valve seals..

Also does the car puff out a while cloud of smoke during cold starts?? if so thats def your valve seals...

I beleive it is possible to just replace one turbo...I THINK its been done but the person said it was more work then just taking off both twins at the same time and bolting 2 back up...
they arent expensive to get a goopd set

ok good luck
dont worry either..these seem like bigger problems then they really
are

Ant
 

·
Registered
Joined
·
81 Posts
Discussion Starter · #3 ·
thanks for the info. On startup it really doesn't belch smoke unless its been sitting for weeks. I suppose I am ok with it, just didnt want to be "that guy" on the road with the ill-maintained supra.

I have been studying the diagrams, and it looks like most of the bolts with the exception of the turbo to manifold lower bolt are pretty easy to get to.

If the turbo is leaking oil past the turbines, is that a clear indicator that the bearings are next? Thanks again
 

·
BLACKOUT
Joined
·
1,864 Posts
start checking your intercooler pipe .....check before the intercooler and after by the intake mani ....you could have a little bit of oil (just a mere coating) in there but not an excesive amount like drips or pooling ....that would indicate the seal being bad .....
 

·
Registered
Joined
·
81 Posts
Discussion Starter · #5 ·
i just installed a fmic, didnt find an excessive amount of oil. Is it possible for the exhaust side seal to be leaking?
 
1 - 5 of 5 Posts
Top