Supra Forums banner

1 - 4 of 4 Posts

·
Supranian
Joined
·
2,007 Posts
Discussion Starter #1
Well a couple of days ago while getting on the highway in bay area rush hour traffic I had to gun the engine to get up to speed and onto the highway before some jackass drove up my ass. Anyway, while racing up to speed I noticed a burning smell (kind of clutchy) and then it was gone. I thought maybe a vehicle in front of me and didn't think too much of it since traffice wasn't moving too fast after that. Later on when I had a chance to make up for some lost time, everytime I started boosting, my car would shudder, almost like it was missing but as soon as I let off the gas and the turbo dropped down it would stop and drive normally.

I was praying that I didn't wipe out my turbo. I checked all of the IC piping and everything looks alright. I checked the turbo wheel and it seems fine also. I am leaning towards a wiped clutch since I already knew mine was on it's way out anyway before this.

My question is....if you are driving normally about 50-60 mph and you jump on it, when the turbo kicks in would your clutch slip and chatter like the car is missing or stuttering???

Any advice would be appreciated.
 

·
Us And Them
Joined
·
1,038 Posts
My non expert advice from what you've told me is that by the souds of it, the bost is just enough for the clutch to slip while under more load than normal driving.

are you running any engine upgrades that are not installed corectly?
 

·
Got Boost?
Joined
·
216 Posts
Im willing to bet that its your clutch without a doubt. Try the 5th gear test. Put the car in 5th gear and rev it up to about 3500rpm and dump the clutch in 5th gear. If the car stalls then the clutch is still gripping tight. If it stays revved up and you start to move a bit or not at all then your clutch is slipping like crazy. If the car doesnt stall then stop immediately to prevent more damage to the flywheel etc.
 

·
Registered
Joined
·
215 Posts
This happens to me on the highway. Not sure what it is, when my car was basically stock last fall when I would be cruising on the highway then go into boost car felt like it would loose traction from extra power maybe and start shaking and what not then reaching 90+ I could smell a burning smell kinda like oil burning i would say. Maybe my clutch is blown to lol
 
1 - 4 of 4 Posts
Top