Supra Forums banner

1 - 8 of 8 Posts

·
Banned
Joined
·
338 Posts
Discussion Starter #1
hi i am looking at a 95 supra with a single swap(T-67) but it is only boosting very low like a 2or 3 psi and the car bogs out when you pass like 3500 rpm, the seller says it is because the cupling that connects the i/c pipe near the passenger fender is not big enough and not holding tight losing air and also with the car in park, went you rev the car it dies out but idles fine. Is this a easy fix or is it a big problem then what the owner says? any info would be great asap

thanks
 

·
Registered
Joined
·
296 Posts
Yup, any loose intercooler components will do what your talking about. Although I wouldnt trust that being the only problem, the bogging at 3500rpm dosent sound like a loose coupling.
 

·
Banned
Joined
·
338 Posts
Discussion Starter #3
Yup, any loose intercooler components will do what your talking about. Although I wouldnt trust that being the only problem, the bogging at 3500rpm dosent sound like a loose coupling.
the owner says its because the engine and turbo is not getting enough air because the cuppling is not holding tight and sometimes when you step on the gas pedal hard when driving, the warning lights blink a couple of seconds and go away. the warning light in the middle of the rpm gauge , the battery light and the low oil light and check engine light all blink and go away. is this normal or is this car a lemon?
 

·
Fast Enough, Never Is.
Joined
·
920 Posts
The I/C piping is definately a problem. Next time you talk to him ask him if you can take it to a mechanic and have him look at it, and see if the car is throwing any codes. Put it this way I wouldn't buy it without checking it out first. If he says no you know there is something wrong.
 

·
Registered
Joined
·
229 Posts
Tell him to replace the hose and clamp, otherwise I wouldn't buy the car based on his diagnosis of the problem. Plus it doesn't make much sense to sell a nice car like a Supra that doesn't drive.
 

·
Registered
Joined
·
963 Posts
my car did the exact same thing when i went single/FMIC.

i tightened my BOV c-clip, and all intercooler piping.

it took care of the bogging, and stalling after revving. Still stalls due to the MAP.

Took me like 4 days to figure out what it was
 
1 - 8 of 8 Posts
Top