Supra Forums banner

1 - 6 of 6 Posts

·
THE NOTORIOUS BHP
Joined
·
4,520 Posts
Discussion Starter #1 (Edited)
Nobody seems to know the name of this sensor. I didnt follow the wiring yet but I believe the vpc connects to it. Anyone recognize it from these pictures or the denso part number showing? Part# search at local toyota turned up nothing?
Do they use non supra denso sensor when installing vpc's? I didn't install it.
You can see the wire and Large wire connector coming off it in picture 2 & 3.




 

·
THE NOTORIOUS BHP
Joined
·
4,520 Posts
Discussion Starter #4
Anyone know where these are sourced from? Apparently is not a stock denso part number for our MKIV's. Do installers source them off another model/make?
The sensor right next to it in my pictures IS a stock MKIV sensor ( Turbo Pressure Sensor ).
I looked up a VPC install write up on MKIV.com and it doesn't mention the sensor I questioned above. It only mentions the MKIV Turbo Pressure Sensor being used.
 

·
Registered
Joined
·
2,293 Posts
Anyone know where these are sourced from? Apparently is not a stock denso part number for our MKIV's. Do installers source them off another model/make?
The sensor right next to it in my pictures IS a stock MKIV sensor ( Turbo Pressure Sensor ).
I looked up a VPC install write up on MKIV.com and it doesn't mention the sensor I questioned above. It only mentions the MKIV Turbo Pressure Sensor being used.
Sure the mkiv install install instructions show this sensor, it's shows with a yellow hose connect to it. Again this sensor comes with the VPC, it is not a Toyota part. As to buying them, I believe they are hard to come by since the VPC is discontinued.
 

·
Registered
Joined
·
1,638 Posts
Jon your going AEM right? You will not need any of those sensors if you do. You will replace them with a 3.5bar or 5bar map sensor from AEM.


Mike
 
1 - 6 of 6 Posts
Top