Supra Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
I've had my car sitting for 4 months with the battery terminals connected. I've tried jumping the car for 30 mins with no luck. Is it possible the battery is completely dead/useless now? It tries to crank while connected to the other battery, but nothing at all without it. Battery is about 5 months old.

Cheers!
 

·
Registered
Joined
·
3,727 Posts
exchange it if you have the warranty. or do a deep cycle recharge and see if that works.
 

·
Registered
Joined
·
710 Posts
The battery is probably almost completely drained at this point. A jump from anything other than a tow truck (high output jump) will unlikely work. Your other option is to put it on a trickle charger and let it charge for a day or so (what Spoolme said).
 

·
BMM
Joined
·
2,329 Posts
^ yeah its probably completely gone. get one of those chargers that Mr. Sinister mentioned, they work pretty well
 
K

·
Guest
Joined
·
0 Posts
slow charge the battery over night (like a few guys have said above). i had the same problem. i store my supra in the winter (3-4 months) i learned now to dissconnect the negative terminal when u let it sit. saves the battery.
 

·
Registered
Joined
·
710 Posts
KVSupra87 said:
slow charge the battery over night (like a few guys have said above). i had the same problem. i store my supra in the winter (3-4 months) i learned now to dissconnect the negative terminal when u let it sit. saves the battery.
Heh. I trickle charge mine every two weeks. I'd disconnect the terminal, but I want my alarm. Now that my garage has been rebuilt, I'll get a battery tender for next winter and just leave the car plugged in.
 
K

·
Guest
Joined
·
0 Posts
same here. i finally cleaned out my garage and made room for my supra. its heated and everything to keep my supra toasty warm in the winter! haha.
 
1 - 7 of 7 Posts
Top