Supra Forums banner

1 - 10 of 10 Posts
R

·
Guest
Joined
·
0 Posts
Discussion Starter #1
Cant get above 14 psi ! ! !

I have a profec b and had it up as high as could goand still never anything above 14.
I then unhooked the two hoses on the turbo and wastegate and recontected the hose to make it factory.Nothing above 12 psi(normal).
And then I did the clamp mod (clamping the hose from turbo to wastegate) and agian nothing above 14 psi.
I did the hose pull mod and got less than 14 psi.

I have tried everything I no to do and i just cant get any higher!
Pleeeeeeeaaaaaaaasssssse Help.........:(
I almost lost to a comaro :mad: ( almost;) )

Thanks a lot

Cory
 
Z

·
Guest
Joined
·
0 Posts
Discussion Starter #3
always check for loose vacuum hoses or loose intercooler pipings before posting this kind of problem, becasue people will just tell you to go backa and check those things. 99% of the time will caused by a boost leak. pull on every vacuum hose you can see, if it comes off easy, change it. a good vacuum hose will be very hard to take off, usually I will have to twist and pull on it quite hard to get it off.

I doubt its your Profec B problem if you had it running right before and never adjust the settings before the low boost problem.
 

·
Registered
Joined
·
658 Posts
get a 2" pipe cap from home depot 88cents
get a tire valve stem drill a hole put in the valve un hook the intercooler pipe on the passenger side form the engine and stick in the pipe cap and tighten it up. use a bicyle pump or a compressor and pump in air up to 18 psi. The closed throttle will hold the pressure at the other end. Measure the pressue after a momtne or two if it leaks down you have a leak in the IC piping and must drop the plastic under engine pan to get to them. If this is okay check all your hoses 2 or thee times( I found a leak at the tube which goes to the master cylinder of the brake resevoir) if no leak is found you will shortly be hearing the death whine. I know because I had the same symptoms you had. The turbo does not always make the death whine also look for a lot of oil in your IC piping that is another sign of a dead or dying turbo.
 
R

·
Guest
Joined
·
0 Posts
Discussion Starter #5
Thanks for your help. I have had intercooler boost leaks before and this isnt acting at all like that.
I will go back and recheck every possible hose I can get too.

Thanks for yalls help.

Cory
 
R

·
Guest
Joined
·
0 Posts
Discussion Starter #6
Thanks for your help. I have had intercooler boost leaks before and this isnt acting at all like that.
I will go back and recheck every possible hose I can get too.
I have noticed a little oil in the turbos but not enouph to worry about.

Thanks for yalls help.

Cory
 
1

·
Guest
Joined
·
0 Posts
Discussion Starter #7
Are you relying on your boost gauge to tell you if you are running the correct psi?? Maybe your boost gauge is wrong.... Try gettin it calibrated to make sure! And if it is brand new, that doesnt mean that it is calibrated...
 
1

·
Guest
Joined
·
0 Posts
Discussion Starter #9
Usually they hook up the gauge to a finite known boost source and make sure the gauge complies. If not they adjust pots in the electronics gauges or the mechanical coil in the mechanical gauge. Performance shops might know where to recommend you to get the gauge checked. if not I am sure you can find places. People have to get regulators checked all the time so it should be pretty easy to find a place.
 
R

·
Guest
Joined
·
0 Posts
Discussion Starter #10
Thank yall very much! Yall were all right!
First I found a very small boost leak that you would ever even guess could make a difference in boost pressure. But it did! It only rose to 15 psi! But I got really pissed and got looking really really close to all the hoses in sight and finaly had to have the car running and got a few inches away from every hose that I could....And I heard it......The slightest hissing from a loose hose on the turbo pressure senser (which my boost gauge is running from) That was IT!! I am running a strong 17 psi now!

I really apreciate yalls help!

Thanks
Cory
 
1 - 10 of 10 Posts
Top