Supra Forums banner

1 - 8 of 8 Posts

·
It will never run...
Joined
·
584 Posts
Discussion Starter #1
After dynoing my car on the wastegate spring because i couldnt get my boost controller to work, which it made 475, my front main seal went out 2 days later, and my crank pulley was cracked. After fixing both and making sure the car was in good working order, i got the boost controller fixed. At 18psi on pump, the car felt very strong. So i decided to put some turbo blue 110 in there. Now it seems as if the car is slower? Can anybody help me out? The boost controller is a evc ez2 which has taken a lot to get to work, and im not sure its working right...
 

·
Never enough
Joined
·
1,418 Posts
Are you on the stock ecu? Paul (a member on this board) noted that he made significantly less power with sunoco 104 than with pump gas at the same timing levels. If on stock ecu, reset it and allow the ECU to advance the timing to a higher degree to make more power.

Andrew
 
B

·
Guest
Joined
·
0 Posts
Midnight Hour said:
It the gas. Get that trash out of your tank and fill up with something better.
so the 110 is bad for the 2JZ? when you say "fill it up with something better" are you saying just standard 91 or 92?
 

·
Registered
Joined
·
1,421 Posts
Higher octane gas burns more slowly. If it is run at identical boost levels with identical timing, it will make less power than worse gas will. Since you didn't reset your ECU your car was probably still running the same timing and obviously the same boost even though you had better gas. Reset your ECU or bump the boost a little (on race gas only since that is a safety) and you will feel the difference.
 

·
Registered
Joined
·
215 Posts
Get a real tuner!!!

Ryan, you need someone who knows what they are doing to tune your car... HINT HINT!!



Dan
 
1 - 8 of 8 Posts
Top