Supra Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter #1
I just got a greddy type s blow off valve and had my car dyno tuned. Now the car shuts off sometimes when I slow down and am going at very low speed. The RPM's seem to get below 1,000 RPM and then go to like 0 and the car turns off. Is this due to this blowoff valve or could it be from having my car tunned wrong in the idle range? Please give me some help guys, having your car shut off while driving and making turns is very dangerous. Thanks.

Will C.
 
1

·
Guest
Joined
·
0 Posts
IF your BOV is venting to atmosphere, this can cause car stall and stutter problems.
 

·
Registered
Joined
·
39 Posts
Discussion Starter #3
I believe it is, How can i fix it so it wont do this. I really like the sound of this blow off valve, so I would like to fix the problem and keep it. How do I fix this?
 
1

·
Guest
Joined
·
0 Posts
if your BOV is welded to an aftermarket hard pipe kit then just put your stock bov in parallel with their aftermarket one. I did this based on other members advice and it stopped the stalling problem. You lose some of the loudness but it stops stalling.
 

·
Registered
Joined
·
39 Posts
Discussion Starter #5
How exactly do I do this? Do you have any instructions you could send me, or some pics of this setup on your car? If you do, could you put them on here or email them to me. Also, will this make the BOV ALOT quieter, because I really like how it sounds right now? Thanks.
 

·
BPU is so 1997
Joined
·
5,349 Posts
This is how my bov is setup. Stock one is still in its original location. I have the Blitz SS by the battery on a hardpipe.
 

·
Registered
Joined
·
39 Posts
Discussion Starter #7
Thanks, but I have a front mount intercooler with hard pipes all around, and my Greddy BOV is mounted already on the side where the turbos are. So I cant put my stock BOV back and move my new one to the TRAC side. Does anyone else have a pic with it on the turbo side, with full hard pipes?
 

·
Registered
Joined
·
255 Posts
badmuthrfkr said:
This is how my bov is setup. Stock one is still in its original location. I have the Blitz SS by the battery on a hardpipe.
Hey bad mofo, do you have any stalling problems or any problems at all with that setup? I had the same setup, stock bov with Blitz SS BOV. If I revved it in neutral the car would drop to like 100 rpm and then come back up to normal idle speed, also it seemed to bleed boost while I was boosting hard.
 
1

·
Guest
Joined
·
0 Posts
I have the blitz bov welded to my fmic hardpipe at it has stall and stutter problems. The bov sometimes sticks open. Usually if I lube it, it helps.
 
1

·
Guest
Joined
·
0 Posts
Here is a pic of my setup. If you look closely you can see the blitz bov welded to the pipe over the intake and you can see the stock bov in its location to help with the stalling problems.
 

·
Registered
Joined
·
255 Posts
Bad Mo Fo thanks for getting back to me. That kinda sucks though what you said. Good luck with the car, it's cool you finally got one.
 
1 - 14 of 14 Posts
Top