Supra Forums banner

1 - 20 of 29 Posts
G

·
Discussion Starter · #1 ·
When I race or step on it it feels like Im hitting boost cut. I have a bcc but wtf? Am I hitting boost cut? What does boost cut feels like? I have gotten my car up to 17.96psi before. I just noticed it just like an hour ago tonight on my way home from work. I was racing a white z28 that was modded up and beat it. After taking him from the line it felt week for like 2sec. What could it be?
Spark plugs bad?
Boost cut?
Boost leak?
Oil change?
ANything?
 

·
488ci V10 Power
Joined
·
1,785 Posts
Change the spark plugs, make sure they are gapped right. all problems fixed. :)

BPU cars generally go through plugs every 5K miles or so. From what i've seen.
 
G

·
Discussion Starter · #3 ·
Yeah I was thinking the same thing I do have ngk6097 or something like that that is fit for bpu but its been like a month now with it in. The car felt stronger like last week but now that pause feeling sucks cuz I feels like Im losing boost(power)
 

·
Registered
Joined
·
1,421 Posts
Give us more info on how this "boost cut" felt. Did the car just stop pulling? Did the RPMs fly up but the car didn't go anywhere? Did the car miss and stutter? Did any dash lights go on? It could be anything from plugs to a slipping tranny.
 

·
Asian Sensation
Joined
·
1,209 Posts
yeah i used to use those shitty autolites, go out a lot. Pop'd up top on boost. NGK's last lil longer. Or could be ur coil packs.
 
G

·
Discussion Starter · #6 ·
VeilsideTT- It feels like a miss and stutter then it will pull hard and then it will do it again. I mean it still run very hard because I went out and tested it out again and I got it to 130mph with ease but it happen 3times before I reach that speed. No dash like on. Althought the dash(engine like and warning lights) did go one like last week at WOT. But I reset it already.

Any ideas?
 

·
Banned
Joined
·
1,981 Posts
I've used NGK 3330/6097 and they both wouldn't last worth a damn in my car. I've been running the autolite 3220 and have found that they last longer and fire better with added boost. My opinion is try the autolites and draw your own conclusion. I was going to buy an HKS DLI but this saved me from doing so. Will see how they hold at 2bar, maybe it will be a different story.
 

·
Registered
Joined
·
1,421 Posts
So did changing the plugs work? How many miles on your car? Could it be old worn out coilpacks?
 
G

·
Discussion Starter · #11 ·
Changing the sparks plug didnt do jack shit. I did notice that there were black marking around the plugs which mean I probaly have a oil leak. Damn valve seal. So I don't know why Im miss firing at full wot. Maybe some back pressure I dont know.
 

·
King Ding-a-ling!
Joined
·
3,198 Posts
I too am having the same problem especially when it gets colder outside. I too am thinking it is plugs/gaps. I want Denso Iridums but don't know which ones to get for a straight bpu car. IK22s?

Brandon
 

·
Registered
Joined
·
12 Posts
IK22 = perfect for stock to BPU
IK24 = Perfect for BPU - BPU+++

NGK

BKR6E = Stock
BKR7E = BPU

This is something i came across on the UK forum. It may help.
 
G

·
Discussion Starter · #16 ·
gapped at .32. So I not the only bpu owner to encounter this problem. Now tell me does it feel sort of like a shifting feeling like if it was a manual? So gapping it down to a .28 might help? I dont see how it would.
 

·
Registered
Joined
·
23 Posts
It sure helped mine. The colder it got outside the more it did it. It felt like a short stutter, like I chopped the throttle real quick and then got back on it. That might be what you are feeling.
 

·
Ex Mkiv TT Owner
Joined
·
137 Posts
if the plugs diddnt do anything then its probly your coil packs. Double check all of the connectors to the coil packs.
 

·
Unstable
Joined
·
370 Posts
Gap to .028 and give it hell! :D
 
G

·
Discussion Starter · #20 ·
gap it to .28

I have seen that when I upgrade turbos and started running higher boost, I would stutter also at WOT. I regaped my plugs down to .28 and it solved the problem.

Alot of us at DSM boards noice that when running over 15psi that we had to gap our plugs down to .28 to keep the car from stutter, the only thing we could figure was the higher boost was causing blow outs in the plug, causing misfires.
 
1 - 20 of 29 Posts
Top