Supra Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter · #1 · (Edited)
Problem's keeping car running...

My car is fucked up the ass it will turn on and the second you lift off ur foot it stalls, it wont charge the battery. also smokes from the hood, almost no exhaust makes it to the muffler most of it comes out of the down pipe, how fucked am i? what do u think the problem is. also makes a horrible noise when i turn right, sounds like i am beating an old bitch to death with a lead pipe. 1991 pos please help
 
G

·
well that sound prity bad it could be a lot of things try taking it in and having aen a grees monky take a look at it
 

·
Registered
Joined
·
32 Posts
Discussion Starter · #3 ·
Let me rephrase what my friend said... Originally when I bought the car, there was obviously some problems with it... It needed a new down pipe, turbo manifold, valve cover gasket / head gasket and the cat was shot. Not to big, but still a bitch to fix. I dropped it off at my mechanic to have him take a look and make sure the diagnoses was right, and he said yes. I left it there for maybe 3 weeks while I was swamped with tests, etc.... I go to pick it up, and it won't idle. It just stalls out the second you take your foot off the gas. This never happend before... and im wondering what's up? What could have happend in those 3 weeks, so on... You need to keep it reved at all times now in order to keep it on, I just don't get it...
 

·
Registered
Joined
·
32 Posts
Discussion Starter · #6 ·
need new tires said:
tps,major vaccum leak, bad wires/ plugs or timming off. check those(basics)


exhaust leak- bad gasket or rusted pipes

-shane
Where do you think the vaccum leak would be? Intercooler pipes, I know I need a new t-manifold, could that be causing the problems? I really want to get working on this beast, but it's just a problem after a problem
 
1 - 6 of 6 Posts
Top