Supra Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
210 Posts
Discussion Starter #1
This morning was the 4th time I have noticed this. When I take my foot off the gas especially between 20-30mph the car keeps going like the cruise is on. The other day it happened at 55mph. Going through the school zone this morning I had my foot off the gas and it cruised right through at 20mph for at least 1/4 mile.
 

·
Banned
Joined
·
330 Posts
is it auto or stick .i had the same problem with my sc 300 ,but it only did it when it is cold .went away after a tranny flush
 

·
Registered
Joined
·
210 Posts
Discussion Starter #3
auto & had the tranny service done 2000 miles ago. Your right I notice it more before it warms up, like within 2 or 3 miles of home.
 

·
King Ding-a-ling!
Joined
·
3,195 Posts
I had this problem on my turbo grand prix back in the day. Everytime it happened, I soon lost the tranny. (I beat the shit out of that car!) I beleive it had something to do with the torque converter not working properly.

Brandon
 

·
Professional OT Bum
Joined
·
654 Posts
If its cold your engine may be on a higher idle speed to warm up, and if your in 4th gear it will idle high and keep you at that cruising speed, unless otherwise I wouldnt worry.
 

·
Registered
Joined
·
210 Posts
Discussion Starter #6
Weird, my car only has 65k miles on it. It shift hard and doesn't even come close to slipping.
 

·
Banned
Joined
·
1,984 Posts
sticking throttle body butterfly can also cause this
clean and regrease the throttle linkage with white lithum grease
 

·
Registered
Joined
·
210 Posts
Discussion Starter #8
sticking throttle body butterfly can also cause this
clean and regrease the throttle linkage with white lithum grease
Where is that on the engine? Do I just follow the throttle cable to the linkage?
 

·
Registered
Joined
·
203 Posts
check your throttle cable also. maybe the cable itself is breaking somewhere causing it to stick. since the cable is a bunch of wires twisted together to cover another wire the outside layer of wires can cause it to stick. fixed a problem like this on a celica. might just wanna check that out.
 

·
wasting my life on SF
Joined
·
1,808 Posts
I had this problem on my turbo grand prix back in the day. Everytime it happened, I soon lost the tranny. (I beat the shit out of that car!) I beleive it had something to do with the torque converter not working properly.

Brandon
it sould slike the torque converter wont disengage like its locked up.
 

·
Registered
Joined
·
922 Posts
It doesn't necessarily sound like there is anything wrong. If the car is in second and idling at XXXX rpm. If that rpm corresponds to a certain speed 20-30mph and the engine at that rpm is producing enough power to maintain that speed why would the car decel.
 
1 - 12 of 12 Posts
Top