Supra Forums banner
1 - 4 of 4 Posts

·
eighty-7t on SM
Joined
·
444 Posts
Discussion Starter · #1 ·
my engine light came on and i pulled the codes. the codes were either 15,17. or i might have read them wrong. could it be 51 and 71?

51: Switch Signal No "IDL" signal, "NSW" signal or "A/C" signal to ECU during diagnostic check A/C switch circuit
A/C switch
A/C amplifier
Throttle position sensor circuit
Throttle position sensor
ECU

71: EGR System malfunction EGR gas temp below predetermined level during EGR operation
Open Circuit in EGR gas temp sensor signal (THG)
EGR system (EGR valve, EGR hose, etc.)
EGR gas temp sensor circuit
EGR gas temp sensor
VSV for EGR
VSV for EGR circuit
ECU

can someone tell me how to fix these? thanks

-jose
 

·
Premium Member
Joined
·
6,130 Posts
chrono said:
my engine light came on and i pulled the codes. the codes were either 15,17. or i might have read them wrong. could it be 51 and 71?

51: Switch Signal No "IDL" signal, "NSW" signal or "A/C" signal to ECU during diagnostic check A/C switch circuit
A/C switch
A/C amplifier
Throttle position sensor circuit
Throttle position sensor
ECU

71: EGR System malfunction EGR gas temp below predetermined level during EGR operation
Open Circuit in EGR gas temp sensor signal (THG)
EGR system (EGR valve, EGR hose, etc.)
EGR gas temp sensor circuit
EGR gas temp sensor
VSV for EGR
VSV for EGR circuit
ECU

can someone tell me how to fix these? thanks

-jose
For 51, just try adjusting the TPS to spec according to the TSRM, and for the 71, I encountered that once, turns out the EGR valve came loose on the head, and it had to be retightened, either that or make sure the harness on the sensor for the EGR is still good, aight good luck man, peace
 
1 - 4 of 4 Posts
Top