Supra Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
70 Posts
Discussion Starter #1
well I was driving and my car started dying and it came back to life. All the lights came on such as the check engine light and the trac light also the oveerdrive light kept blinking off and on. I reset the ecu but it didnt work and also tried a different ingnitor. It seemed it fixed it but the next day the lights came back on and it kept driving fine oh yah the code read a 14 but I don't understand what it is talking about www.mkiv.com . So if anybody has ran into this problem please let me know how to fix it oh yeah its an automatic thanks.:( :( :( :( :( :( :(
 

·
Registered
Joined
·
1,038 Posts
I dont know whats up with mine either... I wired a switch to disable the TRAC fuse, but put it back to stock with wire connectors and a small piece of wire.. now it will come on after a while of driving... probably 30 minutes to an hour, or hard driving... I need to turn off the car, pull trac fuse, reset ecu, put them all back in... and its fine... then it starts back up after a while all over again, no check engine lighte, only TRAC/ Trac off / ! / and O/D Off :(

This problem has been coming up a lot here lately but everyone has a slightly different version of it, I have NO IDEA what to do... the trac fuse IS installed when it happens and is FINE.
 

·
Very Senior Member
Joined
·
9,955 Posts
From '94 Manual
Code 14 is problem with ignition circuit.
may be open or short in IGF circuit from igniter to ECM, bad igniter (I guess not) or bad ECM.
It looks like that there is a lot of stuff to check, according to the manual.
That's all I know.
 

·
Registered
Joined
·
532 Posts
i put my trac fuse back in, but my o/d lite still blinks on and off, i looked at the manuel, and it says that if the lite is blinkin, contact your toyota dealer, they make it seem like a big problem, does any one know what could fix it? or whats wrong??
later
 

·
Registered
Joined
·
70 Posts
Discussion Starter #5
okay I found out why my check engine light kept coming on. A vacuum hose kept blowing off. So check all your vacuum hoses and zip tie them down real good the next day we were driving and my friend had the same vacuum hose blow off. If a hose blows off and the check engine light comes on you must reset the ecu in order to have the lights turn off. so pull the fuses from the fuse box for ten seconds. Thanks for all that replied.
 
Z

·
Guest
Joined
·
0 Posts
my check engine light and TRAC light both comes on and flashes too when I start my engine cold in the morning. it seems like it has something to do with the idle cuz sometimes my idle will jump up-down between 600-1200rpm...very strange. I posted before and someone told me to check the intake air Controller thats located above #5 injector, he told me it controls the idle.
go MKIV.com TECH section under parts photo and you can see pictures of IAC taken apart, I'm gonna have mine replaced and see if it helps.

http://www.mkiv.com/techarticles/parts/iac/index.html
 
1 - 6 of 6 Posts
Top