Supra Forums banner
1 - 10 of 10 Posts

· "Yeah! Take the lemons.."
Joined
·
1,022 Posts
Discussion Starter · #1 · (Edited)
So I'm pretty much done. New hoses, gaskets, spark plugs too idling nicely I adjusted the timing but shes choking and dying when I give any amount of throttle. I'm giving everything attention even jiggling the afm before each start. Only code that's still up is 51 but that makes no sense, I cleaned my throttle body and sensors. The only thing I can think of now is a new fuel filter?
 

· (◕_◕)
Joined
·
8,453 Posts
I think code 51 is the tps sensor. Could be the filter, but I don't think so, especially if you are getting the code.
 

· (◕_◕)
Joined
·
8,453 Posts
Yeah you're right. I cleaned the connections and it looks to be in amazing condition. It's the sensor right on the tb if I'm correct.
Ya should be.
 

· "Yeah! Take the lemons.."
Joined
·
1,022 Posts
Discussion Starter · #5 ·
I got a code 31(afm) too which i thought I cleared but it's still showing up. I don't have engine temp or oil pressure readings either.

Are all these sensors going bad because I dropped in a jdm motor with a usdm ecu?

So much fun!!!:D
 

· Registered
Joined
·
1,403 Posts
if its idle is also shitty, then it's the AFM. if it just stutters a lot under acceleration, it's most likely the TPS. Could be both or could still just be the AFM but my bet would be for TPS
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top