Supra Forums banner

1 - 8 of 8 Posts
I

·
Guest
Joined
·
0 Posts
Discussion Starter #1
When i try moving the car on my MKIV/turbo from 1st gear, my car starts to shake....but if i let very little gas like on 1k, and i release the clutch a little faster, it doesn't...this clutch is weird... now is it supposed to be like that? or is there something wrong with my clutch??
 

·
Registered
Joined
·
763 Posts
iWISHihadaSUPRA said:
When i try moving the car on my MKIV/turbo from 1st gear, my car starts to shake....but if i let very little gas like on 1k, and i release the clutch a little faster, it doesn't...this clutch is weird... now is it supposed to be like that? or is there something wrong with my clutch??
What type of clutch is it?
 
I

·
Guest
Joined
·
0 Posts
Discussion Starter #3
i honestly don't know, but i just wanna know if it's normal or not
 

·
Senior Member
Joined
·
1,522 Posts
My clutch does that also. I have a newly rebuilt factory clutch. Mine shakes like that because it is really tight but It is breaking in now and it doesn't shake much at all. I don't know if this is the same shaking as yours but maybe the info will help.
 
I

·
Guest
Joined
·
0 Posts
Discussion Starter #5
the only time it doesn't shake is if i put little gas like up to 1k, and release the clutch faster, is that what you do??
 

·
Senior Member
Joined
·
1,522 Posts
yea....that is exactly how mine acts. If I try to drive it like a normal car it rattles. It must be because the supra has a really heavy duty clutch and the actual clutch engagement distance is very short on the clutch pedal because it is a tight clutch. I couldn't emagine driving a triple disk clutch around town.
 
I

·
Guest
Joined
·
0 Posts
Discussion Starter #7
lol, i know what you mean...hey how old are you?
 
1 - 8 of 8 Posts
Top