Supra Forums banner

1 - 2 of 2 Posts

·
Over 10 years on SF....
Joined
·
7,892 Posts
Discussion Starter #1
Engine has been torn apart by the previous owner... so I can't exactly tell you what's been done recently but I was told most gaskets, mhg, arps, timing belt for some background info.

Now, the check engine light seems to come on during hard acceleration.. and if I really accel it even kills the car. Also the car very occasionally idles bad... maybe even misses.

The code says it's ECU related... and I will be checking the ECU to make sure it's all working properly but I was wondering if anyone else had similar problems and found it was ECU related and not something else.
 

·
Over 10 years on SF....
Joined
·
7,892 Posts
Discussion Starter #2
Well I got a very good response to this on SM.. so I'll paste it here for reference:
It's caused by a loss of ECU power or ground. Rarely is it the ECU itself.

Intake manifold ground (first thing to check), main efi relay, EFI fuse, etc. The easiest way to track it down (assuming you're not electrically competent) is to jumper around stuff in the circuit until it goes away. You can either jump around individual components or go right from the battery. The battery way is better because it quickly determines whether the problem is on the ground or power side, although in your case it sounds like just wiggling the harness might work.

Code 11 masks all other codes. If they exist they won't be displayed until 11 is resolved...
 
1 - 2 of 2 Posts
Top