Supra Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
487 Posts
Discussion Starter · #1 ·
I got a weird problem here. I run too lean during idle and low load, but I run too rich during heavier load. I have a wideband during idle and low load my afr is 18 to 34 , sometimes it shows 20.9% o2. When it is in heavy load my afr drop to 8 afr. I have Aeromotive AFPR when this happen and my base pressure with vacuum off is 40 psi. I thought the Afpr is messed up so I swithch back to stock FPR. However it still doing the same thing. I want to tune my car with my Emanage. Unfortunately I can't since the ratio is not steady. It keep changing all the time. I remember before I change to Aeromotive AFPR, when cruising at 65 mph my afr is almost 14.7 (+,- 0.1). Now during cruising at 65 mph, it keep changing from 20 to 12 afr. I am lost here. The car drive and boost just. If not for the wideband I would not know I am running too rich or lean other than code 25 and 26.
Thanks
zurud
 

·
This Is Why I'm Hot.....
Joined
·
1,985 Posts
That is a rare code set, but I also experienced it. A stuck fuel injector was the cause in my car's case.

Good luck.
 

·
Registered
Joined
·
487 Posts
Discussion Starter · #3 ·
thanks larry maybe I'll changing my injectors. I got 550 injectors. I really don't know how to put it in. The 550 got o-ring going to the head and stock got plastic seal. Which one to put? The o-ring or plastic seal when using 550. I've ask before but nobody answer.
 
1 - 3 of 3 Posts
Top