Supra Forums banner

1 - 11 of 11 Posts

·
Moderator
Joined
·
2,275 Posts
Discussion Starter #1
Well today i installed my safc II and when i first started the car it was a little rough but slowly got better because the ECU had to relearn and so i turned off the car and put the glove box back in and i started the car up again.

Now i get my engine light is on and i'm pulling code 31! now i know my afm is good. because it wasn't doing this before the safc install. i checked all the wires they seem to be secured so i'm stumped. i read some of idealsupras thread but their was no out come.

any help would be appreciated thanks.
 

·
Is this thing on?
Joined
·
305 Posts
i had that same problem, I unpluged my ECU with the key turned on and then pluged it back in.... it seemed to work but i have no idea for sure.
 

·
No One Ever Listens To Me
Joined
·
5,467 Posts
check to make sure the pink and orange wires are all still connected....if they come off on either side of the connection the ecu will lose the AFM signal and it will act like the afm is broken and throw the code.... that was the outcome of my problem...

HTH
 

·
Moderator
Joined
·
2,275 Posts
Discussion Starter #6
I haven't had a chance to check it out today since it was Easter so sometime during the week ill check that out...

Now does the wire have to be connected and you splice into it or do you cut the wire and run it into that safc? I'm not sure if that makes since or not but maybe somebody might get an idea of what I'm trying to say lol.

thanks guys.
 

·
Moderator
Joined
·
2,275 Posts
Discussion Starter #7
anybody know?^^^
 

·
Moderator
Joined
·
2,275 Posts
Discussion Starter #8
okay I've been looking at this diagram and to me it looks like the airflow wire is cut in half like so now is that right or does the wire half to be connected and you splice into it?
 

·
This Is Why I'm Hot.....
Joined
·
1,984 Posts
silverinferno84 said:
.....Now does the wire have to be connected and you splice into it or do you cut the wire and run it into that safc?.....
If you have to ask that question, then it is highly advisable to have someone else install & tune the unit for you. That diagram cannot be any clearer.
 

·
Moderator
Joined
·
2,275 Posts
Discussion Starter #11
Well i wanted to make sure i wasn't delusional but i just found the problem and now its working right thank you for all your help.
 
1 - 11 of 11 Posts
Top