Supra Forums banner

1 - 11 of 11 Posts

·
Boost is my drug!
Joined
·
1,319 Posts
Discussion Starter #1
I just made a new thread on this so my other one wouldnt get too long and it changes the topic tho.


52=knock sensor
14=ignition (ignitor and coil)
21=O2 sensor
24=intake air temp
34=turbocharger pressure abnormal /maf?
51=A/C switch or tps circutit

anyone can help me out and give me your theory on this..

what should I do.. replace all of them?
where is intake air temp sensor located on?

code 34= turbocharger press abnormal ??????????
 

·
boost freak
Joined
·
10,042 Posts
sounds like you need to take some time to go thru it and fix ALL those problems. w/that many codes, i'd probably reset the ECU and see which ones come back....
 

·
Slowly but Surely
Joined
·
1,438 Posts
i don't know about that way but what i did is i turned the key twice and just pulled out the EFI fuse for about 10 seconds, then the ECU was cleared.
 

·
Premium Member
Joined
·
4,409 Posts
34 and 51 could be ignored for now, and 21 is just an o2 sensor, Probably why your check engine light was coming on...

Go to supras.com and do the knock sensor rewire for 52

As for 14, try swapping a coil pack from another car or an ignitor or something (not sure)

24/??? is that the bad afm one?
 

·
Registered
Joined
·
372 Posts
That many codes at once? I'd try a new ECU! Probably the cheapest route (100 USD used) and if that doesn't solve the problem you can always sell it for the same price later.
 

·
Boost is my drug!
Joined
·
1,319 Posts
Discussion Starter #9
I resetted the code and got code 51 .. all other codes were cleared.. hmm

i just drove it now im gonna check and see what pops up next.


my ecu is fine. my afm is fine
 
A

·
Guest
Joined
·
0 Posts
Mostly Thumbs said:
That many codes at once? I'd try a new ECU! Probably the cheapest route (100 USD used) and if that doesn't solve the problem you can always sell it for the same price later.
:stupid:
 
W

·
Guest
Joined
·
0 Posts
did you mess something up on your safc?? cuz when i first got it i didnt have it set for karmen and my ecu went haywire... i was gettin codes left anf right like you are
 
1 - 11 of 11 Posts
Top