Supra Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
856 Posts
Discussion Starter · #1 ·
I have a problem when am at high boost 18psi and racing on the highway it blows smoke all over. They told me the valve seals are bad and some people tell me its the rings CAN ANYONE HELP and what kind of compress numbers should I be looking for with 90,000 Miles.
 

·
Registered
Joined
·
480 Posts
What exactly happens when you " race " on the highway? check your intake manifold if there is any oil, then check your intercooler pipe that connects with the turbo. if there is oil in the intake manifold its your rings.
 

·
Boost4fun
Joined
·
1,848 Posts
It´s most likely not the valve stem seals since their sympthom is showing up at startup witha blue puff out the exhaust.
Under boost it´s either a very rich condition (black smoke-unburned gas), piston rings or maybe turbo seal(s)..
Just my 0.02

Gerd
 

·
Hardtopper Once Again!
Joined
·
1,709 Posts
I would also do a leak down test if you think your rings may be the problem.
 

·
T88 YOU
Joined
·
3,567 Posts
valve stem seals show smoke when under load (vacuum load, not boost) and on startup, not when you are in boost. could be turbo seals
 

·
Boost4fun
Joined
·
1,848 Posts
Turn it for like 10sec or so for each cylinder until the needle will not go any higher.
 

·
Supra Fender Covers PM me
Joined
·
503 Posts
Remember best way to tell is by comparing the 6 numbers...hot or cold will vary them...so just compare the 6 against each other instead of some numbers in a book.
 
1 - 8 of 8 Posts
Top