Supra Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
I just got my compression test results back and I'm running like sh*t!! The results were horrible. I got 120, 65, 85, 65, 130, 160. As you can tell my the numbers that something is definitely very wrong and I was wondered what could possibly be wrong with my engine. Granted I do alot of racing...is it possible I blew my head gasket and that's the reason for the compression loss? Or do you guys think I need an engine rebuild? After I took out my spark plugs, uhh 3 of them were destroyed and the electrodes were nearly gone. SO, any comments and suggestion? I'm really hoping by some grace of god that I don't have to perform an engine rebuild. Current mods on car...intake, downpipe, exhaust, open wastegate. Any help would be great, thx!
 

·
Registered
Joined
·
18 Posts
Discussion Starter #3
Hehe well my mistake in doing but I didn't ahve a boost controller nor boost gauge. Do you think I'm gonna beed a rebuild? Still hoping it's my gasket. Any sure ways to tell if I need a new head or a rebuild? It's still drivable to say that much.
 

·
Administrator
Joined
·
17,224 Posts
Sounds like you need a rebuild. Your numbers are not only low but the variance between cylinders is huge. Sorry to hear about it.
 

·
Old School
Joined
·
4,014 Posts
SpoolinSupra said:
...is it possible I blew my head gasket and that's the reason for the compression loss? Or do you guys think I need an engine rebuild? After I took out my spark plugs, uhh 3 of them were destroyed and the electrodes were nearly gone.
I doubt you popped the headgasket. It's more likely that you broke some ring lands, put holes in your pistons and/or burned some valves.

That is really hard to do with stock twins.

Gritsak has the right idea, new Toyco shortblock. Plus you'll want to take care of the cylinder head while it's off.
 
1 - 7 of 7 Posts
Top