Supra Forums banner

1 - 20 of 21 Posts

·
Registered
Joined
·
221 Posts
Discussion Starter #1
So I took my supra to atco on friday night for the first time since I did any upgrades to it and I feel like it should have been faster. My best time was a 15.4 at 92mph.
No I have full 3 inch exhaust from the turbo back. cooleze dp, random high flow cat, blitz nur spec cat back, fipk k&n intake, blitz blow off valve. lowered, hks metal head gasket. I feel with these upgrades I should be doing better. Am I wrong or is my car just running like crap like I think it is. It is automatic. what do you guys think I should be running. thanks for your input.
 

·
Registered
Joined
·
221 Posts
Discussion Starter #6
idk i wasnt watching the gauge. But it usually is above 8 and thats all the stock gauge goes to and it doesnt hit fuel cut. so brobally around 10 i guess
 

·
Moderator
Joined
·
4,930 Posts
With autos you need to not hit fuel cut at all during the run, and brake boost at the line to get a good 60 foot time...otherwise you'll get a crappy run.

I know :(
 

·
Always playing catch up
Joined
·
1,632 Posts
what kind of tires? Lowered is not a good thing btw, you need that wheel travel to transfer the weight to the rears, hows the alignment?

can you post up everything on the slip? we need to see your 60' time as the launch kills or makes a run.

personally when my car ran I did a 14.1 with intake, exhaust (to open cutout) and boost controller set to 11ish, did a 1.9 60' on stock size street tires (baytown here is a kickass track) so you should be at least about that fast if not faster since you can build boost off the line.

a link for ya to read up on for the next time you go: http://www.supraforums.com/forum/showthread.php?t=350429

<l><l>
 

·
Registered
Joined
·
1,480 Posts
i was trapping 98 mph, hitting fuel cut at the top of the first 3 gears , with 3" turbo back , a cone filter , and ~10psi
 

·
Banned
Joined
·
4,966 Posts
You need a tune. And most likely you venting your blow off valve isn't helping.
 

·
Just some newb.
Joined
·
1,327 Posts
God your an Idiot DegreE.

He has an auto I doubt his bov even went off once during the entire run.

You do know that the Bov is activated through vacuum. And vacuum occurs when the butterfly closes. He has no reason to let off the accelerator to shift so why would the venting of the blow off valve mater?

He just needs to dial the car in. More boost off the line. Set the camber correctly and get some sticky tires etc.
 

·
Registered
Joined
·
12 Posts
Manual boost controller.
Oh, and I had no first gear IIRC.

What happend to 1st gear? and why would you race a car that isnt running well? I honestly think you got the time you deserve. Fix you car and take it back youll do a lot better.
My car with similar mods and a 5 speed did a 13.9 with a crap 2.4 60ft at 100mph.
 

·
Registered
Joined
·
50 Posts
Sorry sorry, but it wasn't my car and I went to the meeting just for funs. I even didn't brake boost, cause I didn't know what could happen to the gearbox and wanted to get home from there too :D. Though it was supernice to do donuts, ripped my tires into pieces :).
I too think that I really got the time I deserved.
The owner of the car said he took a thing out from the engine compartment that gets the first gear in or something like that to replicate it for another auto car, but idk what he's talking about, so....
I myself have a manual so I can't possibly know.

E: I looked up the results and I was a bit wrong, my second run was a bit better than my first.
Time: 14,73548 reaction: 0,29962 60 ft: 2,56601 km/h155
:chairshot
 

·
Registered
Joined
·
12 Posts
Sorry sorry, but it wasn't my car and I went to the meeting just for funs. I even didn't brake boost, cause I didn't know what could happen to the gearbox and wanted to get home from there too :D. Though it was supernice to do donuts, ripped my tires into pieces :).
I too think that I really got the time I deserved.
The owner of the car said he took a thing out from the engine compartment that gets the first gear in or something like that to replicate it for another auto car, but idk what he's talking about, so....
I myself have a manual so I can't possibly know.

E: I looked up the results and I was a bit wrong, my second run was a bit better than my first.
Time: 14,73548 reaction: 0,29962 60 ft: 2,56601 km/h155
:chairshot
Here's your problem 2.56601 60ft ! every 0.1 you get off your 60ft equals 0.2 at the end of the 1/4 so if you could say get your 60ft down to 2.00 you should run 1.13202 quicker with the same trap speed, so you should run 13.60 ;)
 

·
Registered
Joined
·
3,249 Posts
I run a 13.7/103mph on almost the same mods, but around 13 psi on a stock automatic. Brake boosting from the line is essential, you want the tires just starting to spin as you let off the brake. A little spin off the line got me that time.

I'm interested in seeing if I can still drive now that it's a 5-speed. Maybe I'll head up to Z-max in a couple weeks.
 

·
Registered
Joined
·
221 Posts
Discussion Starter #20
I have toyo bi proxys. I dont spin at all. I did power brake just until the tires started to spin and i kept it in second so it would red line before shifting into third. Unfortunately the left lane at atco wasnt recording the 60 ft and some other things. I just wanted some reasurance that there is something wrong with my car and that it should be faster.
 
1 - 20 of 21 Posts
Top