Supra Forums banner

1 - 18 of 18 Posts

·
Supra gone- Cobra here!
Joined
·
897 Posts
Discussion Starter #1
Good Day, My Supra is a Daily Driver. Yesterday two mechanics installed my Blitz SBC Spec S Boost Controller. We did not get time to set (tune) the Boost Controller as it was getting late. They encouraged me to play around with it alittle in order to get a grip on the volume and mode

As I was driving home, a 50 mile drive and I decided to see how it was boosting. I kept a close eye on the boost controller as I did not want it to spike . I hit the gas going through a tunnel the car downshifted the second turbo spooled up and then a large bang. I quickly pulled to side of freeway. I checked on the boost controller to see how high I had been, 1.2 bar was max boost. As I was pulling over to the side of the road the car was chugging and sputtering. I was able to get in a few miles to a save place and then it started stalling out. It had to park it and get a ride home. I could not check the vacum lines last night as it was to dark.

Again this is my daily driver and technically my only car, I really do need some help from some of the experienced Supra Community as the two mechanics I work with are good, but there knowledge on the car is nothing compared to what I often see here.

To give you insight on what the car was doing last night after the bang. Stalling out,spurtering, no check engine light though. I was still getting vacum, but I could not hear the turbo's spooling or the blowoff valve working.

I need a list of things to check that will align with these symtoms starting with most ovious (easy) to harder and more complicated. Again if you have alot experience with boost controllers and have worked through similar problems please chime in I could really use your expertise

Thanks in advance

Bishop 03
 

·
Registered
Joined
·
1,604 Posts
^Good (realistic) advise. I'll try to be nice since he's a newb. You cannot expect something that was engineered, for a given set of specifications, to perform beyond those specifications without regular mantenance or upgrade to more robust means. Lesson #1 for you- get everything (on your only car) working in top shape before you start to modify!
BTW, carry tools with you so you can put that IC hose back on without bothering anyone else.
 

·
Premium Member
Joined
·
7,335 Posts
I thought blowing an IC pipe off just made the car slow. Never heard of it causing sputtering and stalling???
 

·
Supra gone- Cobra here!
Joined
·
897 Posts
Discussion Starter #6
Black smoke when stepping on the gas

Thanks for your quick response. The car was in tip top shape, I have waited over a year to make sure everything was in top running order before turning up the boost.

In terms of the IC pipe, if it had come off would the car be billowing out black smoke? I just went down to check on it in the light and all the hoses appear to be in good shape and connected.

The car idles well and the vacum appears to be normal, which is it does could it still be the IC pipe?

When you put rev the car up it sputters and almost stalls and quite alot of black smoke comes out.... Still think its an IC pipe?
 

·
Registered
Joined
·
277 Posts
i'm betting its your intercooler pipe. check your pipes
 

·
Supra gone- Cobra here!
Joined
·
897 Posts
Discussion Starter #9
Yes I am still running the stock IC. If the IC pipe is not connected should the car still drive like an N/A, mine certainly does not, when you hit the gas tons of black smoke comes out is that what happened with your car?
 

·
Registered
Joined
·
594 Posts
Yes I am still running the stock IC. If the IC pipe is not connected should the car still drive like an N/A, mine certainly does not, when you hit the gas tons of black smoke comes out is that what happened with your car?

Yes a lot of black smoke! My car wouldn't idle, it would just die when I turned it on, and it would make a very annoying sound. I discovered that a hose on the intake manifold popped off and the IC pipe that went to the stock IC.

I first discovered the hose and thought that was it. I started her up, car didn't die but still blew a lot of black smoke. I kept looking till I found the IC pipe that came off. I reconnected it and everything was fine (next day I ordered the GReedy 3 row).
 

·
Supra gone- Cobra here!
Joined
·
897 Posts
Discussion Starter #12
Thanks I appreciate the responses.

This is pretty much exactly what my car is doing. The only difference is my car will idle but as soon as you put your foot in it black smoke and it will barely run.

In terms of the IC pipe is right under the throttle body on the drivers side? Will a new clamp work to start out with?

Thanks again

Bishop 03
 

·
Registered
Joined
·
222 Posts
my guess is that the black smoke is probably from the engine running too rich because of the lack of air coming in due to a loose pipe somewhere as stated above
 

·
Speed Addicted
Joined
·
702 Posts
This has happened with my car a few times, and that is definitely IC piping. You described it to the T, even the black smoke. And, since you were probably running it at a higher boost than usual, since you have a boost controller now, one of the pipes that wasn't on there very well probably just gave way.
 

·
Speed Addicted
Joined
·
702 Posts
Oh, and I forgot to post above that I was on MAF at the time.
 

·
Old School
Joined
·
4,067 Posts
You can unplug the electrical connection to the MAF to get yourself home if you pop an IC pipe off and are without tools. The car engine will run off the turbo pressure sensor (TPS) as a MAP, but it won't want to be driven hard like this.
 

·
Supra gone- Cobra here!
Joined
·
897 Posts
Discussion Starter #18
Thanks to everyone who contributed in a positive way to this thread. Everything you said was bang on the money right down to unplugging the MAF.

Being up here in non Supra territory, having a community full of knowlegable turners that are willing to help is invaluable resource, thanks again

Cheers and a good Canadian lager to you all

Bishop 03
 
1 - 18 of 18 Posts
Top