Supra Forums banner
1 - 7 of 7 Posts

· The Caravan Aficionado
Joined
·
6,963 Posts
Discussion Starter · #1 ·
I have a 97 na with some simple bolt ons making about 192whp,

I was doing 65mph on the highway last night in 5th gear (w58 trans, w/68000 miles)
and out of no where my rpms jump from 3k to 5k without an increase in speed

i let off the gas.. took it out of gear.. put it back into 5th and gave it gas, thinkning i could induce it again... but it didnt happen again

WTF happened, did my clutch really just slip under normal highway driving conditions?Suggestions?
 

· Registered
Joined
·
11,198 Posts
it couldnt have slipped, you need REAL horsepower to do that, or maybe you spun the tires after you hit boost................oohhhhhh wait, thats right !!!!!!...............hehehehe:bigok:

just playin bro, it sounds like the clutch tho, i hope you get it figured out.
 

· Registered
Joined
·
559 Posts
my clutch slipped on the interstate while i was cruisin around 70. i went to change lanes and the car didn't go anywhere. Once mine strted slipping it wouldn't stop. My rear main seal had started leaking and oil was geting in my clutch.....fun times.
 

· Registered
Joined
·
3,024 Posts
I had similar experiences when my stock clutch finally went after I had been BPU for a while. Of course, in my case, the clutch had to hold back actual POWER worth mentioning (sorry couldn't help it :sadance: ).

Started out only the higher gears under full power, then got to the point that it could slip in any gear under nearly any throttle input. Get your checkbook ready, you're about to get hosed. :agreed:
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top