Supra Forums banner
1 - 20 of 29 Posts

· Registered
Joined
·
357 Posts
Discussion Starter · #1 ·
I got mine in the mail today and it dosent fit well, did anybody else have problems?? Is there any alterations that need to be done?? I cant get the horn to work or the turn signals to return. Please help.
 

· Supra Hoarder...
Joined
·
1,006 Posts
I think Borhor got his to work..


the horn needs to make contact with a wire or something, not just be grounded..
 

· Registered
Joined
·
86 Posts
You need to take a wire from the edge terminal behind the horn button, drill a pilot hole in the hub adaptor, and attach the wire to the screwhole- perferably with wire terminals. The steering wheel hub is the ground point.

I.E.>> power wire comes to horn button, new wire from horn button to momo hub. Push button, get cuircut, get blaring horn sound.
I had to do that on the momo hub on my old MR2.
 

· Registered
Joined
·
357 Posts
Discussion Starter · #10 ·
I spent almost 3 hours and got it to work wtf?? 80 bucks shipped you think it would work as plug and play. I soldered the nubbed plastic piece back to a half an inch. The cruise control terminals wich i dont even have anymore i just removed. Soildered the horn to the gold part behind the hub. Drilled three holes in the rear of the hub to get the turn signals to retract and with the help of goop got everything to work right.
 

· phreshness
Joined
·
288 Posts
i got mine to work, ill have to look at it tomorrow cause i cant remember how i did it.
 

· Registered
Joined
·
720 Posts
Aah some put a write up please i have the same issue !!! i had this ghetto rig going on where the wires were to the actual momo attachment so every time i Turned The wires wrap with the steering wheel xD lolol

I had to have a horn.. It is THAT IMPORTANT in miami....
 

· Banned
Joined
·
5,915 Posts
Aah some put a write up please i have the same issue !!! i had this ghetto rig going on where the wires were to the actual momo attachment so every time i Turned The wires wrap with the steering wheel xD lolol

I had to have a horn.. It is THAT IMPORTANT in miami....

Or you can just yell out the window: "QUE PINGA!!!!!!"
 

· Registered
Joined
·
56 Posts
i got a momo steering wheel my blinkers work but they dont automatically click back after completing a turn.. i have to click it back by hand.. so i usually drive around all day with my blinker on
 

· Registered
Joined
·
56 Posts
i know... ive been trying to figure it out but it's really no explanation for why it wouldnt.. maybe it has something to do with it being a 89 that had that one special steering wheel... i dunno.. it sucks tho
 

· Registered
Joined
·
357 Posts
Discussion Starter · #19 · (Edited)
Sorry no pics....Got a few pm's about this so hit me back if you dont understand...But wasnt hard to do. Time consuming. Just look at the back of the gold plate, you will see the aluminum circle with the holes in it. Around the alum circle is some black like plastic. Get a solder pen and go around the black and remove it. This will cause the plastic cup to come appart from the adaptor, no worries though for the alum groves is the important part that keeps the steering wheel in place. This has to be done for the white ring with the three feet to sit properly around the circle. This is where the goop comes into place, get your slider ring and put grease on the three feet like things on the ring and place it where it sits. Drill the grease markings. The holes can be oversized by twice so dont worry. Clear the holes the best with a pick for plastic debris will set inside. Size up the ring and make shure it sits well in the holes. Goop up the plastic piece that came appart with the adaptor. For the horn you keep the large black ring that sits around the small white plastic ring with the three feet. I nubbed the square with the three prongs from the exisiting wire to the horn down to almost a 1/2 inch. I only kept the one outer terminal/concave like wings which is the horn for I dont have cruise which is the other two. Watch out though, one of the prongs is a ground which is the middle one which is part of the cruise??? if you decide to keep the remaining terminals. You will see when you nubb it down how close they can make contact. I would remove the first and second terminals/concave like wings in the back of this black ring so that the cruse is completly gone. I dont want my horn going off in traffic if they touch. If you have problems getting to the horn terminal for its too tight, you can use the solder pen again to just rub off plastic. The terminal sort of bends and you can pull it up after you remove the plastic by burning it with the solder pen. its easy when you see it. After nubbing them down I simply soildered two inches of wire from the horn on the nubb to the gold part on the back. Its real easy to solder these pecies. Since you also have space behind the adaptor the two inch wire will sit freely and will follow as you spin the steering wheel, so nothing will get tangled. If the t signals dont retract make the holes slightly bigger and play with it for awhile before putting the nut on and tighting it down. Attach the wire from the gold ring that goes thru the adaptor to the horn button and attach the returning wire from horn button to the metal peice that the allen bolts go thru. Enjoy.. I played with it for almost half a day and got it to work great. Hope this helps and feel free to pm me.

Oh goop is a strong glue for those who dont know that can be bought at most hardware stores or automotive. Plumbing or automotive works the same.
 
1 - 20 of 29 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top