Supra Forums banner

1 - 20 of 23 Posts
1

·
Guest
Joined
·
0 Posts
Discussion Starter #1
Does anyone have underhood pic of 86 mkIII??
 
1

·
Guest
Joined
·
0 Posts
Discussion Starter #3
i dont plan on modding my car, i simply bought it for the purpose of geting me back and forth to work and having fun doing that.I am just trying to lern my car and maintenance. the reason for me asking for a pic is because i just bought a manual and the engine pics are so different from what i have in my car and i just wanted to se if they posted a wrong year for the pic? So please anyone who has a pic can you send me it?
 

·
I live in a giant bucket.
Joined
·
1,237 Posts
lol dont worry i was just yankin your chain. i'd help ya out but i have a turbo, and i dont have any pics of my buddies NA engine.
 

·
Registered
Joined
·
590 Posts
Sorry I dont have any really good ones. Someone will probably post better ones for you tommorrow.But this will get you started until then.
 
1

·
Guest
Joined
·
0 Posts
Discussion Starter #6 (Edited)
What is the huge canister in the middle of the intake toob?

My cruise control wont work? any suggestions? is ther a fuse for this??

Also my antena moter works and i hear it working but the antenna does not go up or down? the antena is not jammed eather cause i unscrewed the antena and it opens and closes freely. what could be wrong? also my fog lighst dont go on, the bulbs are good, is there a seperate fuse some were for the foglights that i cant find??
 

·
Republican
Joined
·
8,421 Posts
thats canister i belive is an intake resonator, =quiter intake sound, and more power?
 

·
Registered
Joined
·
2,138 Posts
1986Supra200HP said:
What is the huge canister in the middle of the intake toob?

My cruise control wont work? any suggestions? is ther a fuse for this??

Also my antena moter works and i hear it working but the antenna does not go up or down? the antena is not jammed eather cause i unscrewed the antena and it opens and closes freely. what could be wrong? also my fog lighst dont go on, the bulbs are good, is there a seperate fuse some were for the foglights that i cant find??
I would check all the fuses, then the bulbs, then the motors..most likely it will be the fust or bulb...for the cruise control it might just be a fuse, but check the throttle cable from the cruise control actuator...or maybe the cruise control has been removed completly, and make sure the vacumme host is on the cruise actuator.

My supra is probably the most ghetto'd out supra out there...im soo suprised EVERYTHING works on the car

...except the f'n engine >:O
 

·
Registered
Joined
·
169 Posts
1986Supra200HP said:
i just bought a manual and the engine pics are so different from what i have in my car and i just wanted to se if they posted a wrong year for the pic?
Your probably looking at the 1986 toyota supra engine, not the 1986.5. I did the same thing when I first got my 86.5, but toyota changed the design half way through the year.

-Nick
 

·
Ghetto Rigger Supreme
Joined
·
1,405 Posts
Since everyone is doing it.... what the hell :).

 

·
I work on cars for free!!
Joined
·
503 Posts
1986Supra200HP said:

Also my antena moter works and i hear it working but the antenna does not go up or down? the antena is not jammed eather cause i unscrewed the antena and it opens and closes freely. what could be wrong?
Its busted, remove it and get a regular one for 10.00 they all break over time and a new one is liek 90CDN. the little plastic rail inside breaks over time. Plus the bottom of it is prob rusted out anyway mine was. lol
 

·
Ghetto Rigger Supreme
Joined
·
1,405 Posts
Hehehe yah the car was wet :p.
 

·
ƒ=1/2π(√k/m)
Joined
·
10,086 Posts
clean engine bay....

Stands out due to the white paint inside, and blue outer color.

:bigthumb:
 

·
Ghetto Rigger Supreme
Joined
·
1,405 Posts
Hehehe thanks :), its silver actualy.
 
1 - 20 of 23 Posts
Top