Supra Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3,171 Posts
Discussion Starter #1
So I have the dual 10" box and apparently the targa is significantly hitting the front-top of the box before it even thinks about sliding into the targa mounts.

So, before I go ripping it all out again (all mounted and bolted in pretty) just to find out nothing except what I already know......has anyone else seen this with the dual 10" box??
I was under the impression these boxes fit right from the jump!

thanks
 

·
Banned
Joined
·
302 Posts
I have the 10" box and mine fits perfectly. i'm not sure what is wrong with your box or the way it is mounted, try and move it up a bit see if that helps
 

·
Registered
Joined
·
252 Posts
the website shows a picture of the targa and one 10" enclosure.

i have always wondered about two enclosures. are there any restrictions or limitations keeping the factory carpet, spare tire, and targa fitment by using two enclosures?
 

·
Blue Thunder
Joined
·
3,590 Posts
I have a knock-off and it has the same problem. try to unlatch the seat first, then place the targa in.
It could also be that your speakers protrude too far out.


B
 

·
Registered
Joined
·
3,171 Posts
Discussion Starter #6
I haven't had a chance to rip it all back out yet. It seems it needs to sit down lower in the trench....hopefully I can find a fraction of an inch down there :(
 

·
Registered
Joined
·
442 Posts
Make sure you remove the carpet from that section, No carpet under the box.

Make sure you remove all the mounting bolts from the old stock box.

Make sure the seat is done before placing thebox in

Make sure it is position in a way so it does noot move any more.

I have atleast 20-30 Dual 10" boxes out there. Fitment has never been a problem.

Center of the Targa will touch/Rest on the middle of thebox, But that is part of the design.



 
1 - 7 of 7 Posts
Top