Supra Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
537 Posts
Discussion Starter · #1 · (Edited)
Thought I'd share my results from last week on the dyno. Last year I had Vlad remote tune my NA-T setup which was stock GE motor with a BW SX 61mm. This year it's a built GE VVTi motor out of an IS300, and upgraded to the BW SX-E 64mm (small turbine version).

Was pretty happy with the results. Graph shows comparison of last year (700hp) vs. this year (800hp). Up 100hp and pretty much gained power everywhere, even before the old curve. I'm sure due to the VVTi and also the larger turbo being newer tech so more power with improved aero/spool characteristics.

The final hero pull we had one tiny blip which is the bump in the chart, don't pay too much attention to that.

Overall very happy with the results! Car was completely remote tuned by Vlad on the street. We just brought it to the dyno to see what it would do with pretty much no changes other than adding a couple more degrees of timing. The last pull it was still making more power. We probably could have kept going with timing but decided to just call it good at this point and not push things any further.

Some specs:
92 SC300
2JZGE VVTi out of IS300 (Manley 9:1 Pistons w/ upgraded pins, Manley H-Tuff Rods, Main Girdle)
Head (pocket port, Manley single springs/retainers, Kelford C cams)
Cometic HG (overall compression comes in around ~10.2:1 with this combo)
BW SX-E 64mm (8776 small turbine), TST4 .91AR
CD009 w/ 8.5" QM Twin Disc
Grannas 8.8 w/ 3.27 gears + Wavetrac
Vlad DBW conversion
E85 (particular blend on this day was E80)
Twin in tank 450's (1 alw on, 1 toggled on with boost)
FID 1600 High-Z injectors
AEM Infinity 506 w/ full custom engine harness, remote tuned by Vlad



 

Attachments

·
Registered
Joined
·
149 Posts
Great numbers time to hit the track?
 

·
JetFire
Joined
·
5,416 Posts
Nice numbers especially the torque. Should be fun on the street.
 

·
Boost Junkie
Joined
·
12,688 Posts
Why does the AEM Infinity 506 misfire? My Aem v1 never had misfires.
I'm not saying it's the AEM's fault, but if a car is going to missfire it is more likely to do it at peak torque. That could be related to a miss-gapped sparkplug (too wide) or a weak coil. Definitely not the AEM's fault. I messed up and gapped a plug at .028 instead of .022 and had the same issue. Just one plug was miss gapped and it misfired at peak torque until I fixed it. Annoying AF.

Steve
 

·
Registered
Joined
·
3 Posts
What hanger did you use for the fuel pumps? Would low to see the pump setup and or how you have them hooked up. I have a very similar build that I’m working on.
 
1 - 11 of 11 Posts
Top