Supra Forums banner

1 - 16 of 16 Posts
V

·
Guest
Joined
·
0 Posts
Discussion Starter #1 (Edited)
Took my car to the Dyno last week to get a baseline. My Current Mods are:

HKS VPC
Apexi AFC2
Greddy Boost Gauge
Greggy Profec B Boost Controller
HKS Super Dragger Exhaust
3" Down Pipe
Greddy Blow Off Valve
G-Force Engineering Computer
AEM Cam Gears (Currently set at 0 for both Intake and Exhaust)



HP was 369, 372, and 375....?? Shouldn't this be a bit higher
Tq was 374, 384, and 388....??

HERE is where the problem is, there was a guy at the dyno that has a 718rwhp Supra that told me I needed to dyno it in 5th gear because it is the "True 1 to 1 Ratio" so I did and this is what happened. (Notice the Huge Dip in the Red Dyno Run)



As you can see if was starting to make more horspower, then it went dangerously lean, and didn't recover until 5K. Any suggenstions??? Do the HP number seem a bit Low to anyone???

Thanks Forum for all your Help!!!
 
V

·
Guest
Joined
·
0 Posts
Discussion Starter #2
Forgot to Mention All runs were at 1.5 Bar. It was cold and the Air conditions were perfect.
 

·
Registered
Joined
·
1,196 Posts
Well, I will start with some basic things. Hopefully one of these helps:

-Add fuel! Try to aim to <12. In the last dyno did the car miss fire at all? Did it seem to stumble? Start off by resetting the ecu and leaving all the VPC knobs alone...don't ever touch them. Use the
AFC to tune past 4krpm. You will have no control before that, and attempting to will only cause you to chase your tail.

-Spark plugs? This is a little less likely, but what are you using, what gap, how old are they...etc.?

-4th gear is fine. The only reason you would see a larger number in 5th is due to potentially higher boost from the added load on the engine. A dyno works by measuring torque, and speed. From this it calculated hp. A tire in 4th will produce more torque but also spin slower, and vice versa for 5th. Just stick with 4th.

-Boost control issues? I don't know the profec very well, but I had some large issues when my AVCR tried building boost with the first turbo. On two consecutive pulls I went from 350 to 411rwhp after just resetting the duty cycle.

Good luck, hope I helped.
Daniel
 

·
Medium Ballin'
Joined
·
3,024 Posts
well. your guy is correct on the gear ratios.

1st - 3.827:1
2nd - 2.350:1
3rd - 1.685:1
4th - 1.312:1
5th - 1.00:1
6th - .793:1
 
V

·
Guest
Joined
·
0 Posts
Discussion Starter #5 (Edited)
Daniel,

Thanks for the Info. I bought this car with the Mods, and am just trying to learn about it. I have owned supercharged cars before, but this is my first Turbo Car.

I will Add Fuel and Try Again!! Never Touched the VPC
Plugs are NGK 6097, with a .032 Gap, less than 1K Miles
Yes the last dyno, the 5th Gear Pull did stumble and have a high end miss. Would this be coil packs??

Thanks again for all the Help!!!
Joel
 

·
Former Moderator
Joined
·
3,785 Posts
The HP and Torque results are low considering the amount of boost you were running. It's A LOT of boost for the stock twins. The ECU must have been pulling a lot of timing during those dyno pulls because of the lean AF ratio. You should aim for a bit richer than that. What kind of fuel were you using?

-Olivier
 

·
Registered
Joined
·
1,421 Posts
Holy crap that is lean!!!! What were your AFC settings? That AF seems really weird. I would expect that a 375rwhp BPU car would go rich not lean...
 
V

·
Guest
Joined
·
0 Posts
Discussion Starter #8
Oliver - Amoco 93 Octane, just pump gas.

VeilsideTT- AFC Settings.....?? Good Question. I purchased this car less than a month ago from a guy in Dallas TX. He had it tuned in July By Kenny Tran at Jotech Motorsports to 404hp and 424tq, I just wanted to see what it would do in Kansas City. I did not get an instruction manual with the AFC, so I have no idea how to tune the settings

First Turbo Car, please excuse my ignorance.

Thanks again guys for all your help!!!!
Vinlsol
 

·
Shawn Davis
Joined
·
1,662 Posts
Let's see 22 psi in 5th gear with an AFR >15.0....this should last a long time....

Do you see the jagginess in the plot? That's detonation.

What octane fuel were you running?
 

·
Registered
Joined
·
1,196 Posts
The problems you saw in 5th were due to the EXTREMELY lean condition. There just wasn't enough fuel. The plugs you are running should work fine, but I hope you mean a gap of .032" ;). I would definitely learn the AFC. It is a bit tricky, but once you figure it out it's easy to adjust. I would also be curious what the compression is on the engine. I don't want to scare you as I have no reason to believe it wouldn't be perfect, but it's something else to check.

Again, good luck. It's probably something simple...just have to fingure it out.

Daniel
 

·
Registered
Joined
·
1,421 Posts
He said 93 octane.
1.5 bar is way too much. Keep it around 1.2 or so.

Also, check the settings on the AFC. Just pick the unit up and start playing with it. Youll figure out how to check the settings.
 

·
Mid-life Realization!
Joined
·
2,530 Posts
1.5 bar on 93 octane:eek:

Even with race gas you are beyond the efficiency of your pea shooters at that level of boost and just building heat along with detonation. Beyond the already suggested A/F adjustments, I would at least add a mix of race gas if you are going to run over 15-16PSI as a safe guard.
 
V

·
Guest
Joined
·
0 Posts
Discussion Starter #13
Suprawood - Just finished the Compression Check and there was less than a 2% Variance...........That is a relief!!!
 
V

·
Guest
Joined
·
0 Posts
Discussion Starter #15
I Called Apexi this morning, and they are sending me the manual for it. I have messed with it a little bit, but am afraid of messing something up!!!

Once I get the manual I will learn how to use it, and hopefully go back to the dyno with some Race Fuel.

Suprawood, thanks for all the help!!!
Vinlsol
 

·
Registered
Joined
·
1,339 Posts
put in some 100 unleaded reset your computer and try again with 1.2 as max boost. You will gain 40ish RWHP :)
 
1 - 16 of 16 Posts
Top