Supra Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter · #1 ·
Ok, here’s my scenario, I know this has been posted before but I just want the opinion of others. They say it all comes down to the pin connectors on the ECU. My car door sticker says it’s 02/89. My motor mounts are the round style(see attached photos), my ECU has Grey connectors but the pin #’s are 10, 18, 24. I want to say it is a late 89 but this chart (see photo) says the late 89’s have a 26, 16, 22. And the 87-88 have yellow connectors with the 10, 18, 24. Very confusing, any help will be appreciated. Thank you.
262636

262637

262638
 

·
Super Moderator
Joined
·
11,148 Posts
The round mounts and build date indicate a late 89. The issue you're seeing is that you have a 7M-GE, all of those pin changes were on the 7M-GTE.
If your pinout matches the yellow plug ECU, assume that pinout is valid.
 
  • Like
Reactions: debrucer1

·
Registered
Joined
·
120 Posts
I have the same plugs on my 89, yes it's a little confusing but the pinout is the same as yellow plug, later in the year they actually switched the plug style and not just the color. What issue are you having?

Sent from my SM-N981U using Tapatalk
 

·
Registered
Joined
·
35 Posts
Discussion Starter · #5 ·
I have the same plugs on my 89, yes it's a little confusing but the pinout is the same as yellow plug, later in the year they actually switched the plug style and not just the color. What issue are you having?

Sent from my SM-N981U using Tapatalk
I’m going to be buying a tweaked wiring harness and need to know if it’s late 89 or early. I just wanted to be sure before I go ahead and make an order. Thank you!
 

·
Registered
Joined
·
35 Posts
Discussion Starter · #6 ·
The round mounts and build date indicate a late 89. The issue you're seeing is that you have a 7M-GE, all of those pin changes were on the 7M-GTE.
If your pinout matches the yellow plug ECU, assume that pinout is valid.
Makes sense thanks for clearing that up
 
1 - 6 of 6 Posts
Top