Supra Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have been having this issue for a while now. The car is a 1992 Toyota Supra JZA70 . The car had issues with the Hydro Fan Setup and I had to switch over to a Clutch Fan. Before I did the conversion , the car ran fine , turned over fine , never had issues but sat for a while before the conversion. After the conversion took place , the car had issues starting , it would crank but wouldn't start. I was able to get it to start using two paper clips and bypassing the "Now Failing" Fuel Pump , and it would start. Went ahead and replaced the Fuel Pump with a New Walbro 255 pump , replaced the coilpacks with 2JZ oem coilpacks and it ran okay. The issue had changed from a bogging issue while it ran to an issue upon start up. When the car was warm , it would crank over just fine but when it sat overnight or the engine was cold , it would struggle to turn on. I changed the spark plugs , ECT Sensor , looked at the ECU and it seemed fine , but now it's doing the same thing but just cranking , not turning over. What could be the issue !?!?!? I'm hopeless !!!
251004


251005


251006
 

·
Registered
1987 Toyota Supra
Joined
·
302 Posts
I would start with the CPS.

These ECU's rarely have any issues, not likely the problem.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
I would start with the CPS.

These ECU's rarely have any issues, not likely the problem.
Would this throw a code though ??? Just wondering , I live in NC and had taken it over to Niced Up Motorsports and CJ was able to get my cooling system put in , it's just odd that it happens now and I had 2 codes , o2 sensor & ECT sensor , both have been replaced.
 

·
Registered
1987 Toyota Supra
Joined
·
302 Posts
Nope. Wouldn't throw a code.
 

·
90T
Joined
·
460 Posts
The 1JZ ECUs are known to have electrolytic capacitor problems (over time they dry out). Those look ok in the photo, but its hard to really be sure.
 
1 - 5 of 5 Posts
Top