Supra Forums banner
1 - 10 of 10 Posts

·
Registered
Joined
·
101 Posts
Discussion Starter · #1 ·
hi i have an 89 supra body style and features but sticker vin says aug 88,my car has idleling problems so i did diagnosis code 51 ecu or tps,upon futher investigation i noticed the ecu says 7MGT A/T and it is a used part cause in yellow marker says for 90 supra and it has a grey plug but since i have a manual should"nt it be 7MGT M/T?
second question is since my car is stuck between two body styles changes etc. which ecu can i use i dont know color of plug as wrong ecu in my car i bought it that way with the problems
 

·
Registered
Joined
·
1,104 Posts
search search search. there will be more answers then any of us can give you. plus its good for you because then you wont have to wait for a response. just type in things like "ecu changes" "89 ecu differences" etc
 

·
Destroyer of Turbos
Joined
·
4,461 Posts
hum you can use a A/T ecu in a manual car no problem. at one point someone may have swapped ecus out but its no real big issue.

2nd q: if the plugs are grey you can use the 89+ if it had yellow plugs it would be the pre89 ecu.
 

·
Registered
Joined
·
101 Posts
Discussion Starter · #5 ·
since it works i pulled a 90 auto ecu out of running car and put into mine but same problems rough idle,so i swapped the tps still same problem,so i bought a 89 mt ecu still same problems,but installed stuff back into donor car runs fine,since code 51 is ecu tps or something ac system,i fixed the 2 but the ac system i thinnk has nothing to do with my problems it is broken though,well any suggestions im going to book in car for repair this week.
 

·
Street Sleeper
Joined
·
1,114 Posts
Have you checked for vac leaks?? Plug wires in good condition?? How old are your plugs??
 

·
Registered
Joined
·
101 Posts
Discussion Starter · #7 ·
i have changed the plug wires,coil pack,spark plugs,cps,tps,and an ecu,also adjustments to timing was off,since car is over approximately 1000 rpms over normal smooth idle,i remeber trying to redline it (6500 rpm)and car just died off at 5000rpm mybe somethings off,does a runnuing supra just die when reaches redline,on my 00 celica gts redline is 7800 rpm onced reached engine just stutters but doesnt die off,any suggestions ty
 

·
Registered
Joined
·
1,877 Posts
Something coud be blocking part of your intake. Clogged air filter, sludge in your TB, blockage around your AFM maybe. On the old carbs, blocking off the air intake would choke it causing it to idle higher. Also maybe check your cats if it is a stock exhaust. A blocked cat would make it run sluggish and squelch high throttle.
Check the plug on your AFM to make sure it is fully seated.
Just my 2c.

Edit:
Check your compression and do a leakdown test.
 

·
Registered
Joined
·
1,104 Posts
ecus can be found under the dash...no cords can hook up the usb to the computer unless you had some kind of tuning sorce hooked up.

david nyguen- recalibrate your tps sensor...that'll diff. effect your idle.
 
1 - 10 of 10 Posts
Top