Supra Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
103 Posts
Discussion Starter · #1 ·
Thought I'd post this to see if anyone can help me out here. I have a auto BPU'd '94 Supra TT with sucker fans installed last year. I also have a AVC-R boost controller, EGT gauge, turbo timer, and no stereo amps. Over the past few months, my radar detector often gives me a low voltage signal and even restarts itself at times. I decided to have the alternator checked. It was okay but I figured it might be the internal regulator, so I had it totally rebuilt for $135. Everything was replaced in the alternator.

Now with the new/rebuilt alternator, my battery light comes on from glowing light to medium. And my oil filler light even comes on now with the battery light. I checked the battery after the car is hot and running. It measures 14.12 volts. This morning, I checked it cold and it was around 14.60 while running. So, it looks like it's charging okay.

I checked the 7.5v fuses and they are good. Even replaced them just in case. I did notice that there is a line going to the electric seat fuse (#3 fuse under the dash) with two fuses now going to it instead of one. This may be to my turbo timer. I did replace the seats with electric seats last year.

Is it a possibility that the tensioner isn't tight enough?
Thanks.
 

·
Supra TT Senior
Joined
·
1,887 Posts
Does't sound like a charging issue to me if the battery is hold 14V consistantly.

The radar detector not turning on due to low voltage is pretty normal from my experience. My bel 980 did it maybe twice a year and the person who bought it off me experienced the same thing. I don't think it really affects the way the car runs.
 

·
Registered
Joined
·
103 Posts
Discussion Starter · #3 ·
s14roller said:
Does't sound like a charging issue to me if the battery is hold 14V consistantly.

The radar detector not turning on due to low voltage is pretty normal from my experience. My bel 980 did it maybe twice a year and the person who bought it off me experienced the same thing. I don't think it really affects the way the car runs.
Yeah, but what about the battery light on the dash now being on? I don't care about the detector.
 

·
Registered
Joined
·
103 Posts
Discussion Starter · #6 ·
Swapped out my alternator today with a buddy's alternator to see if the rebuilt alternator is the problem. And yep, the rebuilt alternator is bad. Sunuva...
 
1 - 6 of 6 Posts
Top