Supra Forums banner
1 - 20 of 23 Posts

·
Chasing Leaks 24/7
Joined
·
214 Posts
Discussion Starter · #1 ·
I have it hooked up and running. I have only gotten as far as hooking up the stuff for modding the airflow adjustment map. I will be hooking up the A/F option port to my Wideband, and hooking up the Injectors/Ignition for further tuning. I will probably get to that this weekend. One big issue (not really big, only issue so far) I see is the RPM signal. My readings are way low and am wondering if I need to jumper it for a 12V analog signal versus the 5V digital. So far so good otherwise. I'll keep everyone posted.
 

·
Registered
Joined
·
6,709 Posts
kudos for taking this on!

way to many folks scared of electronics. Keep us posted
 

·
RoastBeefCurtain Commando
Joined
·
6,015 Posts
Im curious to see if you can get the ignition and fuel maps working. I sure as hell couldnt get them to work on the 1J. Greddy Support sucks balls too. Their answer is to buy more parts all the time.
I also couldnt get my wideband to interface correctly.
Kudos for taking the step though.
 

·
Chasing Leaks 24/7
Joined
·
214 Posts
Discussion Starter · #4 ·
figgie said:
kudos for taking this on!

way to many folks scared of electronics. Keep us posted

Don't get me wrong, I was scared as shit to cut apart a perfectly good ECU harness to install this. I was even more worried when it didn't start the first few tries.

I'm going to attempt the wideband install tonight I think.
 

·
Destroyer of Turbos
Joined
·
4,461 Posts
nice man! i have heard some issues with interferance across the harness on other cars so im anxious to see what happens with yours!
 

·
Chasing Leaks 24/7
Joined
·
214 Posts
Discussion Starter · #6 ·
MKIIINA said:
nice man! i have heard some issues with interferance across the harness on other cars so im anxious to see what happens with yours!
Well, I'm trying to eliminate the possibility of interference at least a little bit by staggering the splices and using lots of insulation (electrical tape).
 

·
Registered
Joined
·
6,709 Posts
tkvtec said:
Don't get me wrong, I was scared as shit to cut apart a perfectly good ECU harness to install this. I was even more worried when it didn't start the first few tries.

I'm going to attempt the wideband install tonight I think.

ok not scared

bad choice of words as that is a good reason to be scared ;)

I meant terrified ;)
 

·
Chasing Leaks 24/7
Joined
·
214 Posts
Discussion Starter · #9 ·
OK, so I found out that my dumbass made a mistake when initially tapping into the IGT wire, I didn't tap into the IGT wire. So I fixed that and my RPM readings are just fine now. I'm not sure how I screwed that one up. I also got the Wideband hooked up and started datalogging that as well. I was going to do the injectors tonight, but ran out of daylight. I will most likely get to them this weekend. Probably the ignition as well. We'll see. I'll keep you all posted. Oh yeah, I may hook up the pressure sensor this weekend as well to start logging that too.
 

·
DFWSupras
Joined
·
1,627 Posts
The ideling with the EMU is not a problem from what I found out with local tuners is that the unit is a bit unpredictable. In that I mean that the slightest signal interferance can cause timing and or fuel alterations at high boost leading to engine failure. If you could wire the unit up with shielded wires as directly to the signal it is suppose to get then you could run the unit more reliably.
 

·
Chasing Leaks 24/7
Joined
·
214 Posts
Discussion Starter · #11 ·
I plan to use a shielding tape along with the staggered splices to help reduce interference as much as possible. I'd hate to half ass it and blow something.
 

·
7M POWAH! baby ;)
Joined
·
2,396 Posts
this will make a huge step for other 7m owners... i'd love to use an emu on mine :D
can i ask what maps you chose to run on being that there isn't a 7m to choose from
 

·
Chasing Leaks 24/7
Joined
·
214 Posts
Discussion Starter · #14 ·
suprra_girl said:
this will make a huge step for other 7m owners... i'd love to use an emu on mine :D
can i ask what maps you chose to run on being that there isn't a 7m to choose from

Technically there are no maps to choose from just different engine profiles, which indicate what size engine, what type AFM etc... The EMU just makes adjustments to signals sent to the stock computer's maps. There are maps in the EMU, but they are adjustment maps, not actual fuel/ignition/airflow etc... If you make no changes to the maps on the EMU, everything runs just as though you're running the stock computer.

The profile chosen is for a 3000GT as they are inline 6 3liter with KV afm. The engine code is 6G72
 

·
7M POWAH! baby ;)
Joined
·
2,396 Posts
LOL thats what i meant... i was tired last night haha
awesome stuff... can't wait for updates :)
 

·
Registered
Joined
·
6,709 Posts
tkvtec said:
Technically there are no maps to choose from just different engine profiles, which indicate what size engine, what type AFM etc... The EMU just makes adjustments to signals sent to the stock computer's maps. There are maps in the EMU, but they are adjustment maps, not actual fuel/ignition/airflow etc... If you make no changes to the maps on the EMU, everything runs just as though you're running the stock computer.

The profile chosen is for a 3000GT as they are inline 6 3liter with KV afm. The engine code is 6G72

umm

actually the 3000GT from Mitsubishi is a V6 BUT as long as the firing order is the same it should not be an issue :)
 

·
Chasing Leaks 24/7
Joined
·
214 Posts
Discussion Starter · #17 ·
figgie said:
umm

actually the 3000GT from Mitsubishi is a V6 BUT as long as the firing order is the same it should not be an issue :)
Yes, V6, that's what I meant to say.
 

·
Tree Hugger
Joined
·
823 Posts
Any updates??? I wanna know how you got this running on your 7mgte.

Sorry for bringing up such an old post. But it had good progress!!!
 

·
Chasing Leaks 24/7
Joined
·
214 Posts
Discussion Starter · #19 ·
Any updates??? I wanna know how you got this running on your 7mgte.

Sorry for bringing up such an old post. But it had good progress!!!
Well, to be honest I was making good progress until I blew my turbo late in the Fall. I figured it was so close to Winter I wouldn't replace the turbo til Spring and I haven't really done much with it since. Setting up all the values in the Airflow map to convert to a Pressure sensor is a time consuming PITA. Of course, this is my first attempt at tuning period so I took on a pretty big task for my first tuning project. Aside from setting up the Airflow map everything else seems pretty straight forward. I was able to tune out Fuel cut and because of that and an overtightened BOV I blew the turbo on a hard high boost shift. The car was running its best since I had bought it, but I am still kinda far from getting the pressure sensor setup done. I have it running, but I don't have it tuned well enough for the low rpms and high rpms. Somehow everything in the middle is fine though. I'll reupdate this as I replace the turbo and continue tuning.
 

·
Moderator, l337 M0d3r4t0r
Joined
·
12,263 Posts
try to use the timing trick for the EMB on the EMU

Check it out at my website.
www3.sympatico.ca/zazzn

this will allow the timing to work on the emanage blue and probably the ultimate...
Works like a charm too!
 
1 - 20 of 23 Posts
Top