Supra Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
90 Posts
Discussion Starter #1
ayte when ever i start my car now its idle is twitching around 500rpm and if i give it gas it will barely rise to abour 8-900rpm and if i release the gas it will die on me. after a while of punching the gass it will shoot up to like 4000rpm and then ill release the gas and sometimes it will idle normally but then other times it will countinue to twitch around 500rpm and or stall.

And a few times while im driving and i put my car into neutral and goin about 40mph my motor will die and ill have to start it up again while its rolling or else ill have no break booster or steering assist.

And some times when im already on the road it seams to mis fire from 1750rpm to 2250rpm and my car will just jerk back and forth like im about to stall and this hapens in all gears some times. can any one help me!
 

·
Crow
Joined
·
964 Posts
fuel pump or filter? sounds like your car isnt getting enough

oh, and you dont need that pesky power steering anyway. power steering is for old people :D
 

·
Mr. 2JZUL8R
Joined
·
6,024 Posts
u live in La Puente SoCal?


bro.... Check out my weekly Friday night meets in Rowland Heights at Life Plaza off the 60 freeway at Fullerton Road! we average 10 supras owners a night and we can fix ur problem there within 5mins! socal's best attend and can garuntee u an answer to ur probs and do a quik fix on the spot! :cool: hit me upon emial or AIM to get more detaisl on the location!


sounds more like its boost leak related though! we'll prob check ur AFM as well!
 

·
Mr. 2JZUL8R
Joined
·
6,024 Posts
we were there from 11-11:04pm! cause a fellow SoCal member was having a party at his house! so we went there instead! :p
 
1 - 5 of 5 Posts
Top