Supra Forums banner

1 - 14 of 14 Posts

·
Space for sale
Joined
·
983 Posts
Discussion Starter #1
Well guys, i'm stumped and require assistance...

I am going to do some upgrades ;) but there is something that is bothering me so much that it's making me not want to do it.

There is a nasty ticking noise that's really bothering. It's not really extremely loud, but a faint ticking which ticks quicker as the RPMs go up. I really hope it is just the injectors being dirty, but i am scared that it could be something else... maybe a minor bent valve or something of that sort? lifters?

Could anyone suggest as to what it could be? Maybe i am being too paranoid.
 

·
Registered
Joined
·
1,620 Posts
injector ticking is normal.
 

·
Respect
Joined
·
1,185 Posts
I bet its an exhaust leak. My car makes the EXACT same noise when i had a leak over one of my egr plates. Check your egr stuff or block off plates.
 

·
Registered
Joined
·
2,561 Posts
Yea....check everything the others have stated. Most of the time it's just something like low on oil. Injector noise is normal on higher milage cars, and using some cleaner might help with the noise. I doubt you have a bend valve, and you don't have lifters
 

·
Space for sale
Joined
·
983 Posts
Discussion Starter #6
I actually just changed my oil @ Elmhurst Toyota not too long ago.

If they are really injector ticking, then i am not so worried since i will be getting a fuel upgrade soon. The only thing i am worried about is a bent valve or a retarded lifter, but since we don't have lifters, and .. well, it doesn't sound really too bad, so i hope it's not the bent valve.


Thanks!



Hm.. could still be the exhaust side leak?
 

·
Respect
Joined
·
1,185 Posts
I just fixed mine this morning. It was a tick that went faster as the rpm went up. Exhaust was leaking from the block of plate on the motor side. Start your car with your hood open and grab the throttle body and rev it just a tad a few times and listen. If its not coming from the rear of the intake manifold that scratch that off. Jack up the car, and start it up and check the exhaust to see if its leaking out of there.
 

·
Registered
Joined
·
1,784 Posts
i have this faint ticking also...i can hear the injectors and its noirmal but if i listen really close i can hear anoithet slight tick that is comign from thje engine...i noticed it after racing pretty hard agaiunst a modded z one night..i dont run my car hard that much but this time i was racing a very fast car and had my car at redline a few times...i am not low on oil and i change my oil all the time..i try going under the hood and listening but its very hard to pinpoint and the sound isnt really that loud...i even took ther oil cap off while the engine was runnign and put my ear close by iot and didnt hear any abnormal metal ticking noises or anything..hopefully it is my egr system..i have nbever touched it and its strill working...maybe i will buy the egr plates and disable it..to see if that helps...

hat else could casue a faint ticking...is it possib;le that its something wrong with a valve or would it be much worse if there was a head problem..
also ive had a few toyotas and they always had noisy engines...always ticking or something even when my last toyota had less then 1 mile on it...
 

·
Registered
Joined
·
551 Posts
my timing belt was making a ticking noise before I changed it, how long ago, if ever, was your timing belt changed?
 

·
Space for sale
Joined
·
983 Posts
Discussion Starter #10
JSS829 said:
my timing belt was making a ticking noise before I changed it, how long ago, if ever, was your timing belt changed?
I had my timing belt changed 3 months ago because some of its teeth were missing! :eek: Good thing it didn't pull timing that bad, but then again 2jz's are non-interference so it shouldn't really do much damage if it did...

I'm pretty convinced that it's either the stock injectors or what Jarrett H said. I guess the only way to find out is to upgrade the fuel, and see if still ticks the same!
 

·
Registered
Joined
·
1,421 Posts
Even though we don't have lifters, I've heard valve clearance could be the culprit. I had the same problem come up after a WOT run too. I was told it was the valve clearance but I just ignored it since it went away after a little. Eventually i checked my clearance and 2 of the shims were off...
 

·
Registered
Joined
·
1,784 Posts
yeah i was thinking the shims were off a little bit..i have over 90k on my motor...i am getting my valve seals done this weekend ..how much do valve shims go for ..and do i need them all or to just chnage the ones out of spec...also how bad is it to keep running the car with shims that are out of spec??

anthony
 

·
Registered
Joined
·
1,421 Posts
I'm not 100% but I think clearance being off causes cam wear. Somebody please correct me if that is not the case. As for the shims, I think they are pretty cheap. I recall paying a couple bucks each but don't quote me. Also, I would check to make sure a local dealer has them before you go through the hassle of taking the car apart and then not being able to put it back together that day. The problem of course, is that you don't know what shims you need until the clearance has been measured. Just keep in mind that you can swap shims from valve to valve depending on clearance and shim thickness takin g into account whether swapping them would put both clearances within limits.
 

·
regretfully supraless
Joined
·
1,331 Posts
I have a MKIII but i stumbled across this thread while doing a search for something else...but my car maybes a lot of ticking noise when I'm accelerating...I never thought it to be abnormal, as I had heard other MKIII's making a similiar noise...but I just wanted to double check and get some opinions. Thanks :)
 
1 - 14 of 14 Posts
Top