Supra Forums banner

1 - 5 of 5 Posts
A

·
Guest
Joined
·
0 Posts
Discussion Starter #1
After installing the EGR block-off plate (the single, not double one), I noticed that the idle now jumps between 400-600 rpms. I've done the usual checks on the vacuum hoses and spark plugs. They seem fine. However, there DOES appear to be a "hissing" sound coming from somewhere in that area. Could it be from the VSV located next to the EGR?

Anyone with input? Much appreciated...
 
A

·
Guest
Joined
·
0 Posts
Discussion Starter #2
Awww shucks... I got all excited to read a reply (as indicated was present by an email from Supraforums). OK, I change my original statement... not ANYONE, just ANYONE with constructive advice :)
 

·
Registered
Joined
·
211 Posts
Did you make sure you didn't install it upside down. The blockoff plate shouldn't effect your idle. A few people have installed it upside down and had the same problem you have now.

Long,
 
A

·
Guest
Joined
·
0 Posts
Discussion Starter #4
Ooooh... that could very well be it, althought I hate admitting that I could have overlooked that!!! :(

I will check tonight...
 
A

·
Guest
Joined
·
0 Posts
Discussion Starter #5
Yes, you were right! The block off plate was upside down (I could see an indention of the exhaust gas port... about 1/4 of of it was left uncovered, as shown by an incomplete circle on the plate.

Although I am usually VERY meticulous, it's appears not so in this case. Mental note: don't work on Supra late at night with little sleep previously, no matter how simple the job may appear to be!

Thanks Long...
 
1 - 5 of 5 Posts
Top