Supra Forums banner
1 - 20 of 41 Posts

· Registered
Joined
·
233 Posts
Discussion Starter · #1 ·
There is a new shop in Phoenix called Evil Engineering located off of 40st and Roser. 3702 E. Roser Ste. 12 6026068804. Im usually not one to rep shops but the customer service is what it should be, awesome. They do anything from any kind of custom fab work, coatings, engine builds, machine work, and installations.

The owner is Big John and he really backs up his work. I am extremely impressed with the service there. Anyone looking for a great shop should atleast check them out.

I vouch for them, they did really good work on my supra and the customer service was awesome.
 

· WI-FI FTW, GTFO fuse box!
Joined
·
9,209 Posts
What work did they do to your Supra?
 

· WI-FI FTW, GTFO fuse box!
Joined
·
9,209 Posts
//
 

· Registered
Joined
·
233 Posts
Discussion Starter · #5 ·
I had some fueling and wiring issues. One of the power wires on my fuel pump melted my connector intank. They are also building a turbo manifold and possibly a 3.0 for me. Their fabracator AAron is awesome and can weld like no other.

There is another supra in there getting another turbo kit custom made there and 3 evos getting complete builds. The work they do was great and fast. I appreciated the customer service .
 

· Im A Fuking Ninja!!!
Joined
·
6,330 Posts
sounds good, we need more shops like that
 

· Im A Fuking Ninja!!!
Joined
·
6,330 Posts
found out it was the VSS that was the smoke it was the FMS, repalce that along with everything else in the front while it was being done.. car is soild now.
 

· WI-FI FTW, GTFO fuse box!
Joined
·
9,209 Posts
found out it was the VSS that was the smoke it was the FMS, repalce that along with everything else in the front while it was being done.. car is soild now.
Explain yourself more, like who did the work, found another massive issue, etc.

P.S...oh, it pulls HARD now too!
 

· WI-FI FTW, GTFO fuse box!
Joined
·
9,209 Posts
I had some fueling and wiring issues. One of the power wires on my fuel pump melted my connector intank.
Who installed the fuel system prior?
 

· Im A Fuking Ninja!!!
Joined
·
6,330 Posts
Explain yourself more, like who did the work, found another massive issue, etc.

P.S...oh, it pulls HARD now too!
hahah, i was wondering when you would respond.. JT did the work for me, thank god i did not go cheap and only replaced the FMS, i would have been more of a headach down the line. BTW you over filled the transmission fuild lol.. obo blinks constant now, i'll get it on a lift tomorrow and drain some, no biggie. thanks for the work JT.

back on topic.. as stated before its nice to have options when it comes to tuner shops, glad it worked out for you T51r
 

· WI-FI FTW, GTFO fuse box!
Joined
·
9,209 Posts
** Tony, I didn't have to add tranny fluid! Are you sure you're on level ground while checking? I capped everything off so there was nothing wasted, I hate the smell of that shit+I'm a 6MT lover. I guess I really am a 6 speed guy from birth.:)
 

· Im A Fuking Ninja!!!
Joined
·
6,330 Posts
um.. i'll check it again i guess.. did you notice the overdrive light blinking when you drove it? its annoying, shift fine and all but annoying.
 

· Im A Fuking Ninja!!!
Joined
·
6,330 Posts
i did not, dont think JT did either. so unless it just blew by it self i dont think its that, but it does not hurt to check so can you point me to where that is.
 

· damn '02's...
Joined
·
1,154 Posts
i did not, dont think JT did either. so unless it just blew by it self i dont think its that, but it does not hurt to check so can you point me to where that is.
If I remember correctly (been a LONG time since I pulled one), its the fuse box under the hood, when standing at the driver fender, center row, 4th up from the bottom, 7.5A. :)
 

· Im A Fuking Ninja!!!
Joined
·
6,330 Posts
1 - 20 of 41 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top