Supra Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
124 Posts
Discussion Starter #1
Sorry for that but im just really fustrated. Finally engine is done, it went together really well, started it yesterday let it run at 2500 rpm for 20min or so. The thing sounds awsome.

I hooked up a oil pressure gauge to the engine and im getting a really shitty reading at idle less that 20lbs. I know that before the bhg I was getting about 20lbs at idle and about 45lbs or so when driving.

Now what the fuck Im scared to drive it with pressure that low, I know it will probaly be ok but what will happen after a long highway ride, I dont want to do this again :chairshot . The oil pump is new could it be that I got a non-turbo pump by mistake and its not givin her what she needs or could it be somthing else. Anyone else have this problem after a rebuild the search function isnt working.
 

·
Registered
Joined
·
2,311 Posts
Im pretty sure oil pressure is around 4psi at idle and around 40psi cruising. Go take it for a ride and see what happens. Also are you getting this reading from the stock guage. If so they are not a very accurate gauge. Why would you think its a BHG also?
 

·
Registered
Joined
·
1,719 Posts
Are all your clearances within spec?

edit: what supra8795 said...what are you using to read?
 

·
Registered
Joined
·
124 Posts
Discussion Starter #4
No it was a bhg in the first place I just finished rebuilding it because of that. And no I have a second gauge hooked up directly. I know the one inside the car is shitty.
 

·
Registered
Joined
·
8 Posts
Ya i was totally freaked out when i saw my stock oil pressure guage almost bottom out so i looked in a manual and minimum idle oil pressure is 4.3 psi and at 3000 rpm should be between 36 and 71. 20 psi at idle would make my day.
 

·
Registered
Joined
·
1,247 Posts
^my two 7m mk3s have been that way...
 

·
Registered
Joined
·
3,366 Posts
all you guys need to get your pump replaced, all my mk3s have always read 20 idle 40 crusing
 
1 - 15 of 15 Posts
Top