Supra Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
148 Posts
Discussion Starter #1
Well under about a 1.1-1.3 bar of boost or higher my car latley has been feeling like its missing on high boost. Im running aem stand alone and HKS DLI twin power ignition stock coils. I was wondering if it was most likely that my coils have one foot out the door or if my DLI is possibly not working, having a loose wire or if the aem could possibly do something? My car has 72k miles on it and aem and dli have about 2-3k on em.

Also Im getting a leak i think in the middle of the intake manifold where it comes together. I just had a fuel system put in so i know they took it off.. I highly doubt they put in a new gasket. Is that gasket one that can be reused? If so is it likley that its just some loose bolts?

Thanks for any help
 

·
Supporting Vendor
Joined
·
4,400 Posts
in regards to your intake manifold: one thing you may want to check is your a/f ratio...if your car is monitoring air coming in, then its not getting to your cylinders, that could potentially cause a rich situation in our cars. (in a n/a car it could be a lean situation: boost vs. vacuum) in similar situations to yours...what it usually is, is the stock coils i believe. have you thought about putting on the ls1 coil packs? or maybe just replacing yours? i believe the life is supposed to be in the neighborhood of 60-80k when they take a dump (especially in conjunction with the aem/dli setup) could be wrong, but its definitely something to look at.

Mark
 

·
Registered
Joined
·
148 Posts
Discussion Starter #3
ok i feel better about spending 450$ on new coils.. If they only last between 60-80k I thought maybe my aem and dli just destryoed them, or i have a problem elsewhere.

Im running rich on the fjo but it was tuned to be rich so who knows.. We put compressed air in there and it was leaking some in the back on the manifold. Then it made like a burping sound when we were letting the pressure out. The playback on my boost guage is showing the boost bouncing around some.. Just put a new diaphram in wastegate too.
 

·
Supporting Vendor
Joined
·
4,400 Posts
well dont SOLELY take my word on it...im not an expert, as i dont have coil issues yet, nor do i have an AEM or DLI. just IIRC there have been similar issues and i think the milage is about the same.

i definitely dont want to be the lone cause of you thinning out your wallet...well unless youre buying me stuff ;) :cool:
 
1 - 4 of 4 Posts
Top