Supra Forums banner
1 - 16 of 16 Posts

·
i <3 supra
Joined
·
1,254 Posts
Discussion Starter · #1 ·
hahaha i took out my twins and took off the front turbo, everything checked out, so i moved on to the rear............ compressor side looked fine..... but exhaust side was another story hahahaa my exhuast turbine was gone :bigthumb: time to upgrade
 

·
JZA70 448 rwhp everyday
Joined
·
2,994 Posts
hahaha, u should save that turbo i always save stuff that grenades makes good conversation pieces in the garage.

~scott
 

·
Project:: Reaper
Joined
·
1,401 Posts
HELL YEA i do the same to blown CT26's in my garage as we speak. LOL i ALWAYS bring that thing up. that is some MAJOR damage.

AND YOU THOUGHT IT WAS A BOOST LEAK HAHAHAHAHAHAHA
 

·
i <3 supra
Joined
·
1,254 Posts
Discussion Starter · #10 ·
dunno, can't really remeber, but i ran those turbos hard..... i was planning to go single anyways so this just speeds up the process
 

·
1jz-gte motivation
Joined
·
805 Posts
Same thing happened to my ct26, then again to another one on the cold side. Looked like someone shoved a metal rod in the compressor while it was going at 1 million RPMs.
 

·
*SNICKER SNICKER*
Joined
·
725 Posts
I also did that to a CT26, except the exhaust wheel somehow stayed in the housing, but the impeller shaft snapped in half, much like that one! (I think mine was caused by my failed BOV).

I quit driving mine when mine went. Was afraid the wheel would go thru the block or something stupid and cause even more damage. So I parked mine until I got a replacement CT26 (the car has since been sold).
 
1 - 16 of 16 Posts
Top