Supra Forums banner
1 - 20 of 58 Posts

·
Registered
Joined
·
1,102 Posts
Discussion Starter · #1 · (Edited)
14.9 best :dunno: disappointing

its harder to launch a supra than i thought, thought it would be just like another 240sx or something...

i would either launch to high, or misshift or something!!, nont once had a perfect with no driver errors, sad sad day... Ill have to take some time to get used to this beast, this is only my 3rd time driving it , but im disappointed in myself

Launched from around 5k with e-brake holding me in place to preload the tranny then dropped the e-brake and spun to much...

Then launched to low and took forever to spool the STTs

Then laucched perfectly then missshifted from 3rd to 2nd instead of 4th...

Then launch again somewhat ok, but it wouldnt go in to 3rd because i dropped the clutch to soon...

Mistake after a mistake.... sad day for me... i went to KFC and ate a bunch of chicken!! Then went by this warehouse place with a nice road and practiced launching

Going back on the 8th and hopefully will do much better.

meanwhile... any advice or comments?
 
  • Like
Reactions: RoToPoweRed

·
Registered
Joined
·
234 Posts
What MPH? and also tire pressure, try dropping it 18 psi or so on street tires, and ride the clutch out slightly at launch.
 

·
Registered
Joined
·
2,712 Posts
You need to shoot more shit at Starbucks. A buddy of mine was there and he saw you. Now everyone at Sac thinks supras are slow.
 
G

·
Here are my runs im always in the right lane.

runs 1 and 2


runs 4 and 5 on the 3rd one they gave me the wrong slip.

 
G

·
cummins said:
You need to shoot more shit at Starbucks. A buddy of mine was there and he saw you. Now everyone at Sac thinks supras are slow.
well maybe more supra guys should come out there and represent, i get myself a supra with my noobie track skills and i try to do what i can while you girlies sit at home or at the bleachers and complain.

I admit, i made all the errors, but atleast ill be back there on the 8th of june again and gonna try and get a better time next time, and ill keep trying and practising till i get it all down, before i go ahead and go BPU. Nobody runs stock supras out there, never seen a stock one, they all had DPs exhausts, boosted...

There was one guy out there with another black supra, he did 13.9 his best. His is a N/A-TT 5speed...
 

·
Registered
Joined
·
1,102 Posts
Discussion Starter · #9 ·
Im both MKIV916 and NickT916... i have no idea how it switched my name, since im always on NickT916

so people wont get confused lol
 

·
Registered
Joined
·
2,712 Posts
Are you msivyhuynh too? Calm down dude, relax, take a valume. I did not complain and I'm glad that sac people think supras are slow. I wish I was there to support you!
 

·
Registered
Joined
·
859 Posts
Your MPH should still be higher.......I would start searching for boost leaks.....
You can nearly walk a stock MKIV out of the hole and still crack 103-107 trap and 13's for days.
 

·
I'm very humble.
Joined
·
1,399 Posts
MKIV916 said:
well maybe more supra guys should come out there and represent, i get myself a supra with my noobie track skills and i try to do what i can while you girlies sit at home or at the bleachers and complain.

I admit, i made all the errors, but atleast ill be back there on the 8th of june again and gonna try and get a better time next time, and ill keep trying and practising till i get it all down, before i go ahead and go BPU. Nobody runs stock supras out there, never seen a stock one, they all had DPs exhausts, boosted...

There was one guy out there with another black supra, he did 13.9 his best. His is a N/A-TT 5speed...
show cummins some respect. He is soon to be the quickest supra in nor cal.
 

·
Registered
Joined
·
1,102 Posts
Discussion Starter · #13 ·
cummins said:
Are you msivyhuynh too? Calm down dude, relax, take a valume. I did not complain and I'm glad that sac people think supras are slow. I wish I was there to support you!
just seems like you were putting me down because of my lack of driving skills. My bad, im just a little cranky tonight cuz of my unpleasant night.
 

·
Registered
Joined
·
1,102 Posts
Discussion Starter · #14 ·
whats your supra run cummins?
 

·
Registered
Joined
·
2,712 Posts
With some practice you will get better, but your mph does seem a little low so there may be other things going on with it. I run 49.6 no spray. But since its not on video it did not happen. Take advice from redc5 he has lots of rep points therefore he is someone. I only have 1 so I am no one.
 

·
Registered
Joined
·
859 Posts
Don't be hard on yourself until you know that you car is in proper order.
I went through the same thing my first time out and I found a boost leak......the next time out I went 13.7, 13.6, 13.5

Do you have a boost gauge?
 

·
Registered
Joined
·
234 Posts
Your MPH is way too low, maybe your stock twins are going out? do you feel a secondary pull at higher RPM? or just kinda dies on its face?
 

·
Registered
Joined
·
2,712 Posts
team702 said:
Your MPH is way too low, maybe your stock twins are going out? do you feel a secondary pull at higher RPM? or just kinda dies on its face?
This could be true. If your twins are going out then just go single. Lance Armstrong seems to do just fine.
 

·
Registered
Joined
·
1,102 Posts
Discussion Starter · #20 ·
NSANITY said:
Don't be hard on yourself until you know that you car is in proper order.
I went through the same thing my first time out and I found a boost leak......the next time out I went 13.7, 13.6, 13.5

Do you have a boost gauge?
all these good times people get. No i didnt get a chance to get a boost gauge yet, il prob be getting one in a few days and put it in and see if my boost is dropping or whats going on. I did a boost leak test and did find a leak where the BOV is connected, so i fixed that, but i also noticed that the pressure doesnt stay in the engine that long after i put in some air in there. Id pump up like 15 psi in for like 30 seconds or do then stop and listen but seems like its escaping somewhere but i cant hear it, i thought maybe its coming out through the oil cap? so im not sure if the pressure supposed to stay in the engine or some of it escaping somewhere is normal? (should the engine act like a tires is what im asking)



Accel Junky said:
What were your 60fts? I ran my stock MKIV TT 6spd last friday and got a best of 13.863 at 103.8 but my 60fts were crappy at 2.33-2.4's
i added those 4 slips from my runs and my 60 were pretty bad actually kinda like yours 2.2 was my best. but i still dont see how you are getting 13.8 where im barrely getting 14.9 , hmm!!!

i might have to take it in to this supra shop here in teh city see what they say.


team702 said:
Your MPH is way too low, maybe your stock twins are going out? do you feel a secondary pull at higher RPM? or just kinda dies on its face?
i do feel more pull after the 4k and do feel the 2nd kicking in , but this is on my daily driving, at the track i have no time to feel when its kicking in, but i do know when its pulling tho.

this is kinda frustrating now that i think it could be the second turbo. Im hoping its just a boost leak. :dunno:
 
1 - 20 of 58 Posts
Top